[SOLVED] installation of sam core

Hello…

I’ve upgraded IDE to the latest version (1.6.8 ) from 1.5.8. Now I discovered that due core is not included by default and have to be imported. Unfortunately automatic importing thing did not worked, but the address for the archive that IDE attempted to download was visible.
So I’ve manually downloaded it something that goes by the name sam-1.6.7.tar.bz2

Inside was a folder called sam

In the Arduino folder located in Program files I found a folder called hardware.
Inside that Hardware folder there was another folder called avr.
So I’ve moved the sam folder from downloaded archive in to the hardware folder - next to avr.

Now in the core downloaded of the IDE the core 1.6.7 for DUE is marked INSTALLED.

However attempts to compile and upload anything to the due board result in error message:
exec: “/bin/arm-none-eabi-g++”: file does not exist
Error compiling for board Arduino Due (Programming Port).

This is the whole message…
There was a similar post made back in 2015, best solution they came up to was to install IDE version 1.5.8

I’m wondering if nowadays there is another solution…

P.s. I suspect that it’s the firewall that prevents the DUE core to downloaded automatically, I’ve allowed Adruino to connect to internet but it made no difference to the downloader.

This is the error message that I get when automatic download fails:

Error downloading http://downloads.arduino.cc/cores/sam-1.6.6.tar.bz2
java.lang.RuntimeException: java.lang.Exception: Error downloading http://downloads.arduino.cc/cores/sam-1.6.6.tar.bz2
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$20(ContributionManagerUI.java:176)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.Exception: Error downloading http://downloads.arduino.cc/cores/sam-1.6.6.tar.bz2
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:113)
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:67)
at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:103)
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$20(ContributionManagerUI.java:173)
… 1 more
Caused by: java.net.SocketException: Socket is not connected: connect
at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
at sun.net.www.http.HttpClient.(HttpClient.java:211)
at sun.net.www.http.HttpClient.New(HttpClient.java:308)
at sun.net.www.http.HttpClient.New(HttpClient.java:326)
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1169)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1148)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:999)
at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:933)
at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:170)
at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:128)
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:111)
… 4 more
Could not find boards.txt in C:\Users\Uga\Documents\Arduino\hardware\attiny\variants. Is it pre-1.5?
WARNING: Error loading hardware folder C:\Users\Uga\Documents\Arduino\hardware\attiny
No valid hardware definitions found in folder attiny.
WARNING: Error loading hardware folder C:\Users\Uga\Documents\Arduino\hardware\breadboard
No valid hardware definitions found in folder breadboard.
Could not find boards.txt in C:\Users\Uga\Documents\Arduino\hardware\mighty1284p\bootloaders. Is it pre-1.5?
Could not find boards.txt in C:\Users\Uga\Documents\Arduino\hardware\mighty1284p\cores. Is it pre-1.5?
Could not find boards.txt in C:\Users\Uga\Documents\Arduino\hardware\mighty1284p\variants. Is it pre-1.5?
WARNING: Error loading hardware folder C:\Users\Uga\Documents\Arduino\hardware\mighty1284p
No valid hardware definitions found in folder mighty1284p.

I've installed a previous version (1.6.6) as well.

The weirdest part of the story is that this file is actually present in this version!! So I've copied sam core in to this version's folder but it still does not work. Than I've copied the entire gcc-arm-none-eabi-4.8.3-2014q1 folder in to equivalent location in 1.6.8 version, but unfortunately it does not work as well.

C:\Program Files (x86)\Arduino\hardware\tools\gcc-arm-none-eabi-4.8.3-2014q1\bin\arm-none-eabi-g++.exe

Can you please look on your computer in which folders the sam core and \bin\arm-none-eabi-g++.exe suppose to be?

Thank you.

I am having similar issues. I started working with UNO and IDE V1.6.8. All worked fine, then I wanted to port the code to DUE and I've spent over a day trying to make it work. Someone suggested to use IDE V1.5.6. with DUE, but that IDE is pretty old and I don't see why I need to revert to old IDE to make DUE to work. With 1.6.9 or 1.6.8 I can not even install the SAM for M-3 Core. Is anyone else having these issues?

Thanks in advance when Binary is not enough; TriBit should do it...

AlfaOmega/TryBit

Question: After click in Tools -> Board: "Arduino/Genuino Uno" -> Boards Manager... what do you get? Do you get a red error at the bottom of the Boards Manager window saying "Error downloading http://downloads.arduino.cc/packages/package_index.json"? If so, you have Internet connection issues.

Lately, I have done the upgrade to IDE 1.6.8 with Windows XP, 7 and 8 flawlessly.

Also, I have used prior IDEs for months and I get what I need for my Due. Since IDE 1.6.0 most of the improvements/new features in the latest IDE releases are not particularly for SAM (Arduino Due) but for AVR.

-p

I’ve managed to solve it.

As Palliser suggested that it’s an internet connection issue.

I’ve come to realise that it’s not Arduino IDE that tries and fails to download this core but JAVA.

Then I’ve allowed Java to access internet (in firewall settings) and everything happened like a charm from this this point on.

Hurray!!

you can find the URL for the latest sam core here:

https://downloads.arduino.cc/packages/package_index.json