[SOLVED] Issue with Arduino Mega + RS232 + HyperTerminal


I used this tutorial and made the board with MAX232N (Texas Instruments): http://arduino.cc/es/Tutorial/ArduinoSoftwareRS232 (Spanish)
Only, I bought the cable.
And I use an Arduino Mega 2560.

The issue is that the code in the link is not working, I need to send through the port of Arduino Mega Serial3 text to PC (using PC for initial tests and receiving correctly see on screen, then I will use another device).
Why not print correctly the message with this code?

 void setup () {
   Serial3.begin (57600);

void loop () {
   Serial3.println ("Hello World");
   delay (5000);

Instead of getting "Hello World" receives " ' ' ' ' "(without the quotes, I receive apostrophes, which means that it receives something, but wrong).

The configuration of the HyperTerminal in Windows XP is the same as the link above, only the 9600 modified by 57600 (the one that uses the device I'm using).

Any idea about what happens?

A greetings and thank you very much.

Could you try a simple serial terminal.
I use the Q Serial Terminal, http://qst.sourceforge.net/
Don't use any handshake.

You better start with the default 9600 baud.
Could you upload a photo of the MAX232 with the wires and connections ?

Thank you!!!

I solved the problem, the cable was damaged. With another new cable, the issue disappeared :slight_smile: