[Solved] ITEAD SIM900-GPRS-GSM-Modul doesn't work

Hello,
i have the following module http://www.exp-tech.de/Shields/ITEAD-SIM900-GPRS-GSM-minimum-system-module.html
and an arduino Mega 2560 with this library: GitHub - jgarland79/GSM_Shield: GSM Library for the SIM900 chip and the GBoard Arduino GSM development board

The indicator LED blinks every 3000ms so according to http://www.exp-tech.de/service/datasheet/GRPS_module_DS.pdf that means:
“SIM900 registered to the network”

Testing an example-sketch like:

/* GSM Shield example
 
 created 2011
 by Boris Landoni
 
 This example code is in the public domain.

 
 http://www.open-electronics.org
 http://www.futurashop.it
 */

#include <SoftwareSerial.h>
#include <GSM_Shield.h>
//for enable disable debug rem or not the string       #define DEBUG_PRINT
// definition of instance of GSM class
GSM gsm;



void setup() {
  Serial.begin(9600);
  Serial.println("system startup"); 
  //gsm.InitSerLine(9600);   //initialize serial 1 
  gsm.TurnOn(9600);              //module power on
  //gsm.InitSerLine(9600);   //initialize serial 1 
  gsm.InitParam(PARAM_SET_1);//configure the module  
  gsm.Echo(1);               //enable AT echo 
}


void loop()
{
  
    int reg;
    reg=gsm.CheckRegistration();
    switch (reg){    
      case REG_NOT_REGISTERED:
        Serial.println("not registered");
        break;
      case REG_REGISTERED:
        Serial.println("GSM module is registered");      
        break;
      case REG_NO_RESPONSE:
        Serial.println("GSM doesn't response");
        break;
      case REG_COMM_LINE_BUSY:
        Serial.println("comm line is not free");
        break;
    }
    delay(2000);
    
    reg=gsm.IsRegistered();
      Serial.print("Registration ");
      Serial.println(reg);
    
    delay(50000);
}

I get the output:
“GSM doesn’t response
Registration 0”

Can anyone say me to which pins i have to connect the RX and TX of the module?
And what else could be the mistake?

Nathax

Did you disable the PIN on the simcard? double check with a cellphone. Is there enough money on the simcard? Double check with a cellphone.

That shield use upto 2A so make sure you have a big enough power supply. The USB power supply is generally not big enough in this case. I used a 9V, 2A power supply connected to the Arduino's barrel connector to get mine to work properly.

I guess your connection to the GSM network is fine. Please remeber the external power! Sometimes it works without…
Your RXTX pins are probably wrong, you can change them in the gsm.cpp at the beginning.
Always look at theese instructions about SoftwareSerial:

Not all pins on the Mega and Mega 2560 support change interrupts,
so only the following can be used for RX:
10, 11, 12, 13, 50, 51, 52, 53, 62, 63, 64, 65, 66, 67, 68, 69

Regards!

Thank you for trying to help me.

My SIM has no PIN and enough money on it.

In which way should i change the GSM.cpp?

The beginning is:

#define rxPin 2
#define txPin 3

//SoftwareSerial mySerial =  SoftwareSerial(rxPin, txPin);
SoftwareSerial mySerial(2, 3);  //rx, tx

Isn't it useless to change rxPin and txPin if SoftwareSerial mySerial(2, 3); uses predefined integers as parameters?

Right, but you use an arduino Mega, so use for example SoftwareSerial (10,3) or like me (50,51).

I "accidentally" also used pin 50 and 51 to try and it worked perfect. :) Thanks for help, mates. No external power supply was needed.