[SOLVED]linux : arduino IDE need superuser rights?

Hello

I just installed mint v19 and wanted to get the Arduino IDE
The software manager version is quite old, so I got the latest directly on the arduino website (arduino-1.8.7-linux64.tar.xz)
I extracted it, then I ran the install.sh file

everything went OK, a shortcut was created in the menu, it runs fine, but I can't upload any sketch to my board.

name@computer:~$ /home/name/Programmes/arduino-1.8.7/arduino

it does exactly the same as the shortcut ... as expected !

BUT if I run

name@computer:~$ sudo /home/name/Programmes/arduino-1.8.7/arduino

it asks for my password and then runs it properly, no problem to upload...

So it is not really a problem since I can use it anyway, but I am quite sure ther is a way to run it simply without a password as I used to !

Anyone who knows how to solve this?

thanks a lot !

Some linux flavors assign the serial device ports (ie /dev/tty.usbserial) to a specific group ownership, to prevent valuable resources like dialout modems from being accessed by "normal" users.

See linux - avrdude: ser_open(): can't open device "/dev/ttyACM0": Device or resource busy - Stack Overflow

I was already in the dialout group

The problem was that every solution I found talked about /dev/ttyACM0

Since my port (in the IDE /port/menu) was /dev/ttyUSB0, I had to change the usual command I found in several forums

sudo chmod a+rw /dev/ttyACM0

to :

sudo chmod a+rw /dev/ttyUSB0

simple as that...

Thanks for helping a big noob ! Will be much easier this way !