[Solved][Linux] Sim800C Bluetooth Firmware Upgrade Tool

Good afternoon,
I'm having problem to upgrade SIM800C module firmware as I'm using Linux and couldn't find any tutorial around that and I found mtkdownload tool
sim800_Series_update_tool_src_linux_v1.03.rar
but it's command line help shows below

$ ./mtkdownload                        
Usage: mtkdownload <com> ROM_VIVA <format>

<com>: /dev/ttyS0,/dev/ttyS1,/dev/ttyS2..
means  COM1,COM2,COM3,COM4,USB2COM
ROM_VIVA is updating rom file
<format> Y,N
means  format FAT or not format Fat
Example: mtkdownload 100 ROM_VIVA Y

and Arduino port is /dev/ttyACM0 so I used

./mtkdownload /dev/ttyACM0 ./ROM_VIVA Y

and it always print same the above lines, What was wrong?

Also tried using /dev/ttyS0 as the port

$ ./mtkdownload /dev/ttyS0  ./ROM_VIVA Y
configure complete
start send and receive data
fcntl=0
isatty success!
fd-open=3
Filename : ./ROM_VIVA
Filesize : 2547000 bytes
 len=2547000     
Power On/Reset Target

notes: I don't use any extra modules to flash, just Arduino Uno connected to SIM800c (UART way if i'm not wrong) as below

Arduino --> Sim800c
5v --> VCC
GND --> GND
RX --> RX
TX --> TX

PDF Guide: https://simcom.ee/documents/SIM800x/SIM800%20Series_Software%20Upgrade_Application%20Note_V1.04.pdf

Thank you in advance

It's solved as missing connection between RST & GND on arduino