[Solved] Missing Compilation report

Unfortunately, we're not out of the woods yet! When I use to editor to compile, it still says "Success: Done verifying. Blink" but it no longer gives a compilation report in the output window, nor does it give you a detailed error report if there is an error in the sketch.

I used to get a message like this:

arduino-builder/arduino-builder -compile -core-api-version 10611 -build-path /tmp/802259546 -hardware arduino-builder/hardware -hardware arduino-builder/packages/cores -tools arduino-builder/tools -tools arduino-builder/packages/tools -built-in-libraries arduino-builder/latest -libraries /tmp/623624487/pinned -libraries /tmp/623624487/custom -fqbn arduino:avr:uno -verbose=false /tmp/623624487/Blink
Sketch uses 928 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

But not anymore. Is this how the editor now works, or could another bug have crept in... Am I the only one this happening too?

Best regards

Keith

@kickitharder, that's odd!
I just tried to compile the blink for a UNO and a MEGA and I get the full output (with the Verbose Output option checked in the Preferences) and the normal output you mentioned without that option.,

What OS + Browser are you using?
What board are you using?
Can you share the sketch?
Could you post a screenshot?

Thanks!

The same error here.

When ONLY Compiling it says success, but no report and when Compiling- Uploading it shows an empty error (no logs at all) and says to report the issue here.

I took a look at the developers tools in Chrome:

Url: https://api-builder.arduino.cc/builder/v1/compile
Method: Post
Address: 52.70.42.127:443
Status Code: 412 Precondition Failed

Board: Arduino UNO
Browser+OS: Chrome on Windows 10

When compiling-only and compiling-uploading, i think the code when compiling-only don’t handle the error from the server as well as the compiling-uploading code.

Here is the console log from Chrome just when clicking the compile-upload button, the difference is when compiling-only it only throws the error from the POST request and not the error ‘data’ of undefined.

angular.e8da26a5.js:1 [serial monitor] - try close
api-builder.arduino.cc/builder/v1/compile:1 POST https://api-builder.arduino.cc/builder/v1/compile 412 (Precondition Failed)
vendor.9f44a072.js:5 TypeError: Cannot read property 'data' of undefined
    at angular.e8da26a5.js:2
    at h (vendor.9f44a072.js:5)
    at vendor.9f44a072.js:5
    at n.$eval (vendor.9f44a072.js:5)
    at n.$digest (vendor.9f44a072.js:5)
    at n.$apply (vendor.9f44a072.js:5)
    at f (vendor.9f44a072.js:5)
    at q (vendor.9f44a072.js:5)
    at XMLHttpRequest.v.onload (vendor.9f44a072.js:5)
(anonymous) @ vendor.9f44a072.js:5
(anonymous) @ vendor.9f44a072.js:5
h @ vendor.9f44a072.js:5
(anonymous) @ vendor.9f44a072.js:5
$eval @ vendor.9f44a072.js:5
$digest @ vendor.9f44a072.js:5
$apply @ vendor.9f44a072.js:5
f @ vendor.9f44a072.js:5
q @ vendor.9f44a072.js:5
v.onload @ vendor.9f44a072.js:5

Hi OOalis

Thank you for your response - my preferences had the "Console: Show verbose report" box unchecked.

Problem solved and all is good!

Many thanks

Keith

I see they solved the problem with the server, i can compile again :slight_smile: thanks

Glad this works :slight_smile: sorry for the inconvenience