[solved] MKR WiFi 1010 not executes uploaded sketch

Hi,

First of all, my setup:

  • Win10
  • Arduino IDE 1.8.13
  • MKR WiFi 1010 board (WiFiNINA v 1.3.0)

I recently bought a new MKR WiFi 1010 and I'm facing an unexpected behavior.
I uploaded the "Blink" sketch successfully but when I unplug USB from my laptop and I plug it into a wall usb port (the one I use to charge my smartphone/tablet) the MKR WiFi 1010 board turns on (the power led - the green one - is on) but doesn't execute the uploaded sketch .... the led doesn't blink.
If I unplug the board from the wall usb port and plug it back again into my laptop the sketch still doesn't get executed.
After that, if I open the Serial Monitor of Arduino IDE, it starts to execute the Blink sketch.
I'm not understanding why it doesn't execute the sketch automatically but, you know, I never tried other board than Arduino UNO Rev3 and ESP8266!
What's happening?
Can you help me?
Thank you
Alex

remove
while (!Serial);

@AGIDevelop

Your topic was Moved to it's current location / section as it is more suitable.

Could you also take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

@Juraj thanks! I feel so stupid :slight_smile: The solution was already in my hands.