[Solved]MKR1000 not recognized...

...when using USB on the following environment:

OS: OSX 10.11.5 Browser: Safari 9.1.1 or Chrome 51 Driver: ArduinoCreateAgent 1.1

Hi @mamu, we can't reproduce that issue, could you please check if the desktop IDE recognize it?

Nope, not in the IDE on my MacBook nor on my iMac. Do I have to configure the board or install a special driver (I'm new to MKR1000)? Yes, I do have to double tab the reset button to enable serial/usb com.

Yep on the Desktop IDE you need to install the specific core, here the Getting Started guide https://www.arduino.cc/en/Guide/MKR1000

Let us know! Thank you!!

And for the Web Editor one has to install nothing, BUT one has to activate serial communication which is disable at factory settings. You do this by double tapping the Reset button. https://www.arduino.cc/en/Guide/MKR1000 states:

If this doesn't solve the issue, manually put the CPU into bootloader mode, this is accomplished by pressing quickly twice the reset button (you need a pencil to actually push the button).

Hi,
on desktop IDE please check :
From board manager that the latest core (currently 1.6.6) is installed
From the library manager the latest wifi101 library (0.9.1) in installed

do you have uploaded some sketch on the board?

please try also with another micro usb cable, disconnecting all the other USB cables except the MKR1000 one.
fast double tap also normally resolves any issue you may find.

BTW the serial communication is NOT disabled in factory.

Let us know.
thanks!
Andrea