(SOLVED)Multiple YunShields Not Always Visible on Local Network

Hello All,

I have a requirement to have multiple YunShields connected to my local network, but have run into an issue while working on two of them. Sometimes I can see both YunShields on the network and sometimes I can only see one or the other. That is I have one at 10.11.26.214 and another at 10.11.26 236. My colleague has the one at 10.11.26 236 connected to his workstation, but right now he can not see it in the Ports option in his IDE. I am working on the one at 10.11.26.214. If I unplug mine, he will be able to see 10.11.26 236, but then I will not be able to see 10.11.26.214 when I plug it back in even after I can ping it.

I am going to have to have about 10 YunShields running on my network and will need to be able to access then all consistently. Does anyone have any ideas why they are not consistently visible on the network? Is it some setting(s) that I have missed?

@ShapeShifter - I read you thread on distributed communication using Yuns. Can you access them all consistently via your network?

Thank you in advance,
Murrah Boswell

otrcomm:
::::SNIP::::

I am going to have to have about 10 YunShields running on my network and will need to be able to access then all consistently. Does anyone have any ideas why they are not consistently visible on the network? Is it some setting(s) that I have missed?

::::SNIP::::

@otrcomm,
having worked with robotics and wifi in the same general environment, I can tell you if you want to "test and deploy", then use wired. Once you are past that, then you can have some reasonable assertion about the usability of a wifi networked system.

However, if you are time critical, time dependent, or might create a physical hazard, use wired.

If you have specific questions, I can answer then - as can Shapeshifter (of course).

Jesse

I've not had time to realize the goal of the distributed system, so I have not had all four Yun's on the network long term. But I have had one or two on at a time, sometimes for a week or two, but have not had connection problems. But, like Jesse, I try to use a wired connection whenever possible.

In fact, I must use wired if I want to try to access them from the IDE, as my computer is on the wired network and the required broadcasts from the Yun to make it appear in the IDE won't cross my wired/wireless boundary. Even so, there are many times that a board does not appear in the networked port list, even though the Yun is accessible by other means.

I really wish there was a way to manually configure a list of boards/address in the IDE, the current scheme of relying on the reception of a broadcast message is not reliable enough for my tastes.

I did have general connectivity problems recently, and tracked it down to the two active Yun's both being named arduino, so that the address arduino.local was ambiguous. Did you assign different names to each Unit?

ShapeShifter:
...
I did have general connectivity problems recently, and tracked it down to the two active Yun's both being named arduino, so that the address arduino.local was ambiguous. Did you assign different names to each Unit?

Agree 100%.

Change host name method:

nano /etc/config/system
...
option hostname 'Arduino'
...
reboot

Change hostname via API:

uci set  system.@system[0].hostname=Arduino12345
uci commit system
hostname Arduino12345
/etc/init.d/avahi-daemon restart

All of the Yun Shields are connected to my local network via wired interfaces.

To all thank you,

Changing the hostnames of the Yun Shields corrected the issue. Hopefully this will be permanent so the shields are always accessible.

I will wait for a few more hours before I mark this thread Solved.

Thank you all again,
Murrah Boswell

otrcomm:
Changing the hostnames of the Yun Shields corrected the issue. Hopefully this will be permanent so the shields are always accessible.

It should be permanent, but is likely to be reset if/when you do a system upgrade and load a new OpenWRT version on to the Linux processor.

Besides the methods that sonnyyu gave, you can also set the host name using the first field of the basic configuration web page (the one where you can set the password and timezone, and select a wireless network.)

@ShapeShifter

Thank you, I did change the hostnames on a few of the shields via the Web page. I also changed a few via the way that sonnyyu suggested.

Regards,
Murrah Boswell