SOLVED - Nano RP2040 Connect not working, tried everything

I have 2 RP2040 Connect boards, bought from different sellers (one of them was the arduino store) with months apart .
Tried 2 pc's (Win 10 and Win 11), 1 mac M1
4 different usb cables
All the reset options that I found on the interwebs
Im working with arduino for 10 years now. Programming since I was 12years old (im 44 now).
It's not showning up as COM port nor as mass storage.
I really need help :frowning:

Hi, welcome to the forum.

Which tutorial did you follow ?
Have you uploaded the UF2 file to blink the led ?
I had problems with the Raspberry Pi Pico but in the end it worked in Windows: Can not upload to Raspberry Pi Pico

Hi, I tried the ones on this page: https://support.arduino.cc/hc/en-us/articles/4404168794514-Nano-RP2040-Connect-not-being-detected-on-USB-port
I tried IDE version 1.18.16 and 2.0.0 beta 12
I cannot upload the blink, the com port or mass storage does not show up. (Both boards)
Tried your solution, still not working.

If you are not able to reset it or drop a UF2 file on it, then I don't know what else you can do :cry: Do you have an other computer with Windows ? Does the RGB led do something ?

Perhaps @pert might be able to help.

Possible bad USB cable??

What happens when you double tap the reset button fast? Does the onboard LED fade in and out? Does it open a mass storage?

I literally tried 4 cables which worked for me in the past. I ordered a new cable with the 480 Mbit specifications and it works!

1 Like

bamoo77,

Don't credit me too much. I have worked too many times with the power switch off, power cord unplugged, fuse blown, looking in the wrong place. Way too often with a witness. That burns a hole in your heart.

Right now I have an HP Windows 10 machine with 2019 BIOS. It is a USB 2.0 machine. I have added a USB 3.0 four port card to get USB 3.0. For reasons I can't understand I can access the CIRCUITPY file system on various RP2040 devices, BUT I can't access the RPI-RP2 boot file system on the USB 3.0 ports. All is good on the USB 2.0 ports.

Good judgment comes from experience, experience comes from bad judgement.

Bruce