[solved] Open a .pde file from the command line (linux)

I want to be able to do 'arduino test.pde' have have arduino open the .pde file and not a blank file.

I found this: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1284958834 But when I added the $1 to the end it didn't change anything.

The arduino script changes the current working directory to /usr/share/arduino, did you specify the full path to your pde? if not you'll open a blank sketch

even if I do: arduino /home/phil/programming/Arduino/test/test.pde

I still get a blank sketch

EDIT:

if I do:

echo $0 echo $1 java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base /home/phil/programming/Arduino/test/test.pde

then run the command: "arduino lol" I get: /usr/share/arduino/arduino {blank line here where $1 should be aka lol}

then it opens the program with the proper sketch loaded, so the $1 parameter isn't getting passed properly

Figured it out: http://gunnewiek.com/2011/open-pde-files-with-arduino-ide-in-linux/