[Solved] Powering the Nano from a 5.1V power source

I have an Arduino Nano setup connected to an NRF24L01 module (with 5V adapter) and a KY-023 joystick. When I power it through the USB port it works fine. But when use the same supply to power the Nano through the 5V and the GND pin, it does not work. It does light up but it is not transmitting. Also, the TX led o the Nano starts flashing very fast when I attempt to power it from the 5V,GND pins. I am not powering the Nano through the Vin pin since I read the supply needs to be 7V or above.

Circuit in picture below:
Imgur

Update
Apparently the problem was with the specific Arduino Nano unit. I swapped the Nano in the transmitter with the Nanon in the receiver (the receiver works with 7.4V fed to the VIN pin) and everything worked fine.

What are you powering it with?

This:

When using the USB output it works. When I use one of the 5V outputs on the side to power the Nano using the 5V and GND pin, it does not, even though I can measure 5.1V on that output.

Edit: Powering it with any 5V source through the 5V and GND pins appears to have the same effect.

Hi,
@ospreygozo battery pack.

Do you have a DMM?

Can you please post picture(s) of your project, both sides please?
Can you please post a circuit diagram?

Tom... :smiley: :+1: :coffee: :australia:

Here you go: