[Solved] Problem adding custom lib

Hi there!

I’m trying to add the lib u8glib for supporting OLEDs to my Create based sketch but I’m not able to add it. No error or something else. Adding other libs worked quite well and on local installed version of u8glib everything is alright.
I get the zip file from here: GitHub - olikraus/u8glib: Arduino Monochrom Graphics Library for LCDs and OLEDs

Thanks for your report, it might be a similar problem as in http://forum.arduino.cc/index.php?topic=398512.0
Would you tell us what browser and OS you are using?

We will debug this issue in the next few days, thanks for your report!

I tried it using Chrome 50 and Safari 9.1 both on OS X 10.11.4 and had no luck.
Maybe it's the same issue but according to not getting any error messages, it is hard to say.

Why is there a limit of 1 MB when uploading libs?
There are some libs around that a bigger than that because of some additional sample code.

You are totally right and we have a PR ready to modify that, would 2.5MB make more sense?
We just need to make sure people upload libraries and not other stuff (sounds weird but it does happen)

Maybe it would make more sense to check the content?
And yes, regarding my lib 2.5 MB would be enough .

BTW: the reason for the big size of the lib I use (u8glib) ist that it contains fonts for drawing on OLEDs.

Checking the content is not as straight forward as it may seem, for instance you have fonts in your lib :smiley:
Testing now the fix, hopefully will be online in the next few days.

Thanks!

Please test again now, we have deployed the fix, thanks!

Yep, worked like a charm!

But know, my board is not recognized. But I know it already was :frowning:
Using Plug-in version 1.1
Safari 9.1.1
OSX 10.11.5
Chrome 50

what board are you using?

China made Nano 3.0 clone.
It was found when I made the first tests some weeks ago. (and still gets found be the on-premise Arduino IDE)
Maybe it has to do with the latest OS X update? kext-driver issue?

BTW it is CH340 based with ATMEL MEGA 328P

That's very interesting, as we are not showing any metadata info on clones. Not sure why it was showing up last week actually :slight_smile:

Weird. Did you mean you currently do not support clone Arduinos?

no, we just support official Arduino and Genuino boards, testing out all the clones will be an epic job so we cannot guarantee for them.

In the board dropdown you can click 'Select Other Boards and Ports', select the compatible board and port and it should work :slight_smile:

00alis:
In the board dropdown you can click ‘Select Other Boards and Ports’, select the compatible board and port and it should work :slight_smile:

That is what I do but there is no port shown and I can only select the Nano board. I think there is a problem between the current plug-in and OS X version. Because I know it worked including the the debugging console.

BTW: I do not expect that you do any tests regarding clone boards.

So you installed some additional drivers to get the CH340 working on the Java IDE, right?
I tried with a clone myself and you are right, to the the CH*** chip we are not detecting the port at all.

Let me know :slight_smile:

00alis:
So you installed some additional drivers to get the CH340 working on the Java IDE, right?

Exactly. I installed this one www.mac-usb-serial.com

Just for your interest: Using codebenders driver, I can use my board in their editor using Chrome.

It is working!!
Please see “Update 2”

What I did:

  • unsinstalled codebenders FTDI driver incl. all dirs using terminal
  • uninstalled ArduinoCreateAgent 1.1 incl. all dirs using terminal
  • re-installed ArduinoCreateAgent 1.1
  • shut the Mac down (due to a heavy thunderstorm here)
  • rebooted the Mac
  • connected the board to a different usb port as it was before

Update 1:
Sadly, it is still not stable. Somehow OS X crashed after disconnecting the usb port. After several installs and uninstalls it did not crash anymore but the board disappeared from Create :frowning:

Update 2:
Deinstalled additional CH341 driver from www.mac-usb-serial.com. The crash es were caused by the additional CH341 driver.

et voilà → china Arduino clone works on my machine incl. serial monitor and the custom u8g lib which started this thread!