SOLVED...problem after updating avr-g++ library

I am using version 1.6.6

I have been ignoring updating libraries boxes in the bottom left of the sketch screen for a while 'cos I seem to remember updating once before and having all sorts of problems.

Can't happen again, right?

I have just conceded and updated the file avr-g++, now I am getting

error compiling.

avr-g++: error missing filename after '-o'

when I compile, even if I compile the examples / bare minimum sketch. Anyone know a way of correcting this?

:::added::: I have just noticed the copy error box, does this help?

Arduino: 1.6.6 (Windows 7), Board: "Arduino Nano, ATmega328"

avr-g++: error: missing filename after '-o'

exit status 1 Error compiling.

This report would have more information with "Show verbose output during compilation" enabled in File > Preferences.

This is a common problem. @pert usually addresses it like so:-

pert: The error is caused by using Arduino AVR Boards 1.6.10 with Arduino IDE 1.6.6, they are incompatible. The solution is to either:

  • Upgrade to Arduino IDE 1.6.7 or greater
  • Install Arduino AVR Boards 1.6.9 using Boards Manager(Tools > Board > Boards Manager... > Arduino AVR Boards(click on it) > Select version > 1.6.9 > Install) - I've had problems reinstalling the previous Arduino AVR Boards version with Boards Manager so you may have to reinstall the Arduino IDE if you can't compile after going back to Arduino AVR Boards 1.6.9.

Just an update on that statement, Arduino AVR Boards 1.6.11 is also incompatible with Arduino IDE 1.6.6. That combination will cause the same error.

N.B. Personally, I'd suggest that if you decide to upgrade the IDE, go for version 1.6.9 or V1.6.11. (I prefer 1.6.9, it's nice and stable.) Ignore IDE V1.6.7, 1.6.8 and 1.6.10. They have more than their share of problems, (as did V1.6.6 for that matter).

thank you Steve I will stow that one away for further help if needed.

I went to the boards manager and installed the version 1.6.9. I closed and reopened the IDE but when I tried to compile I got the same.

I went back to boards manager and it showed I was on 1.6.10 so I installed the 1.6.9 again. this time it worked and I am back to the IDE working again.

Thank you so much.