[SOLVED]Problem during arduino Uno Sketch upload

Hello makers,
I have arduino uno clone board. I used it since couple of year. I did plenty of projects using it till now.

Since two days I am unable to download programs on it. During investigation my observation is as below.

01, If I connect usb cable of uno into my laptop and immediately connect serial monitor then it connects. And it runs last program as I got all serial print messages, or blink of pin13.

02, If I disconnect serial monitor(not power) & try to reconnect serial monitor it didn't got connects afterwards.

Only way to reconnect is by following step-01as mentioned above.

03, if I connect usb of uno to laptop and immediately download new code then it got successfully downloaded and worked.

04, if I try to download another sketch(without power restart) then it didn't downloaded as uno didn't connects.
Again if I follow step03 then I am able to download any sketche.

Remark:- I tried pressing reset button just before download starts but it didn't worked aswell.

Summary:- arduino connects with PC within short period of time after power up. After few seconds of power up instance it refuse to connect.

Assumption:- as this behaviour is time dependent, I my assumption is :- any one capacitor of my board is faulty. But I don't know which one.
I assume its ftdi chip releted capacitor which holds tx pin of uno after certain time of power up the board.

Kindly suggest which part of base bord got damaged??

Most clones do not use FTDI.

Could you take a few moments to Learn How To Use The Forum.
It will help you get the best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks @Robin2 )
  • Add your sketch where applicable but please use CODE TAGS ( </> )
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can

COMMON ISSUES

  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks @Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.

COMPUTER RELATED

  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent

ARDUINO SPECIFIC BOARDS

  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/ArduinoCreateAgent.app/Contents/MacOS/config.ini
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.
Language problem ?
Try a language closer to your native language:

Thanks to all those who helped and added to this list.
[/quote]

1 Like

Just a SWAG but it sounds like the laptop driver software got updated if it worked properly before.

I don't think so. Because all my other bords are connecting fine.

Thanks for pointing out.
I will take care next time.

I have tried on anothervPC & it works. So it's driver problem.

Thanks.