[Solved] Problem interfacing HC-11 with arduino nano

I have 2 HC11 modules and i am able to send AT commands to both the modules.However i am finding it difficult to communicate between both.

Here is my code,

#include <SoftwareSerial.h>

SoftwareSerial mySerial(10, 11);

void setup() {
  Serial.begin(9600);            
  mySerial.begin(9600);              

}

void loop() {
  if (Serial.available()>0) {        
    String input = Serial.readString();
    mySerial.println(input);
  }
  if (mySerial.available()>0) {     
   String input = mySerial.readString();
   Serial.println(input);
  }
 
}

i have attached image showing AT configuration of both the modules.

my connections for both the modules are as follows
HC-11 - Nano
RXD - 11
TxD - 10
GND - Gnd
Vcc - 5v
SET - LOW (in command mode i.e while sending AT i connected it to ground and during Transparent mode floating)

i also tried connecting SET to High on both sides (sender and receiver) but still nothing worked for me.

In my setup i have connected two HC-11 modules to same computer through nano ,one to com4 and another one to com6 and i opened two instances of ide (one on port 4 and another on port6).But when i send text using serial terminal nothing appeared.i tried loopback test of both module both are working fine But wireless transmission is not happening.

Edit:if anyone still come here looking for answer maybe its problem with Mode so try operating both on FU3 mode.

for FU3 mode:
SET - LOW
open terminal at 9600 baud
Then enter “AT+FU3” it should return OK-FU3 .
DO this on both device
Then remove SET pin from LOW(or leave it floating )
then open 2 instances of ide and 2 serial terminals.
start sending text from one terminal and it will appear on the other.
thats it.

If you are using HC-11 in very short distance it will not work because of oversteering the analog circuits. Like described in the manual. Using FU3 lowers the transmission rate and the power. When doing this over more distance - why do you want those modules for desk distances? - all the other FU settings should work.
As ever: RTFD - read the fine datasheet.

i posted it as solved isn't it.i have read the datasheet fine and thanks for the advice