Solved Problem. MIssing USB-port in Linux.

I had a simple piece of code with UITEthernet. Just blink a LED in port 13. I went on uploading the code to Arduino Nano. The IDE told that it is not possible. In Tools the Port had disappeared. USB memory stick worked OK. In Linux terminal lsusb gave no connection.. In /dev there was no ttyUSBx, and dmesg gave this over and over:

[ 2470.432740] usb 1-2: new full-speed USB device number 29 using xhci_hcd [ 2470.544882] usb 1-2: Device not responding to setup address. [ 2470.748941] usb 1-2: Device not responding to setup address. [ 2470.953111] usb 1-2: device not accepting address 29, error -71

I changed Arduino Nano and agoin to the third, Same problem. No usefull help from Google.

Then I took the USB connector out,in,out,in,out,in as fast as I could. Now all my Arduinos work again.

Then I took the USB connector out,in,out,in,out,in as fast as I could.

Sounds like it was a contact problem. Removing and inserting again causes the metal contacts to rub against each other again and remove some oxidation etc..

I have been know to make really important connections the first time -- 8 times in and out. And insert and remove Memory DIMMs 4 times..

I would hate to think it's Superstition!

The xhci_hcd looks like USB 3.0 host hardware. I have had some strange problems with the USB 3 hardware on my Windows 10 computer.

In my case, it may have been CMOS latch-up. I had to pull the power plug for a while to clear the problem. I think the latch-up is aggravated by USB devices that lack a soft-start start circuit.

Anyway, my Linux computers work fine without the soft-start but they are old and only have USB 2. I have added a soft-start to a board I made if you want a reference.

|500x313

Basically, the soft-start is a P-CH MOSFET that is slowly turned on, it just keeps the inrush current from getting too high.

Perhaps with the Nano, it would be best to use a USB 2 port or an external powered hub that handles some of the inrush currents from the hot-plug outside the computer.

I will test the connections as terryking228 succests. I didn’t believe there is problems there, because this cable works 100% with other devices but everything is possible. If there is something, it must be on the Nano side connector.
I’ll try to find another cable.