[solved] Problem uploading boot loader to Mega2560.

Hi,
Sorry to invade this topic but I didn't want to open a new one as it I have a similar problem to the OP. I am attempting to use an Arduino UNO to add a bootloader to an Arduino Mega 2560. I have the set up correct and the bootloader attempts to flash the 2560 but it fails and I get the following message -

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega2560 -cstk500v1 -PCOM3 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xFD:m -Uhfuse:w:0xD8:m -Ulfuse:w:0xFF:m

avrdude: Version 6.3-20190619
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3
Using Programmer : stk500v1
Overriding Baud Rate : 19200
AVR Part : ATmega2560
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PA0
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 10 8 0 no 4096 8 0 9000 9000 0x00 0x00
flash 65 10 256 0 yes 262144 256 1024 4500 4500 0x00 0x00
lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : STK500
Description : Atmel STK500 Version 1.x firmware
Hardware Version: 2
Firmware Version: 1.18
Topcard : Unknown
Vtarget : 0.0 V
Varef : 0.0 V
Oscillator : Off
SCK period : 0.1 us

Error while burning bootloader.
avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.02s

avrdude: Device signature = 0x1e9703 (probably m1280)
avrdude: Expected signature for ATmega2560 is 1E 98 01
Double check chip, or use -F to override this check.

avrdude done. Thank you.

My question is, as a tyro and having never done any serious programming and am unfamiliar with avrdude.conf, where and how do I use the -F parameter in avrdude?

TerryD15:
where do I use the -F in avrdude

It's very rare that using -F to override the signature check is helpful. That is only useful in a case where the signature has somehow been corrupted on your microcontroller. In this case, I suspect the signature is correct and you have a rare ATmega1280-based Mega board instead of the more common ATmega2560-based Mega. You can check this by looking at the writing on top of the largest black chip on your Mega. If it says "ATMEGA1280", then you need to select Tools > Processor > ATmega1280 in the Arduino IDE. If it says "ATMEGA2560", then there might be a case for using -F, and I could provide instructions for that, but we'll cross that bridge if we come to it.

I've deleted your other cross-post @TerryD15.

Cross-posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes (or more) writing a detailed answer on this topic, without knowing that someone else already did the same in the other topic.

Repeated cross-posting will result in a suspension from the forum.

In the future, please take some time to pick the forum board that best suits the topic of your question and then only post once to that forum board. This is basic forum etiquette, as explained in the sticky "How to use this forum - please read." post you will find at the top of every forum board. It contains a lot of other useful information. Please read it.

Thanks in advance for your cooperation.

Hi,

I do apologise for the 'cross posting' and thank you for a solution, I originally wanted to delete this post here as I had not used the correct method of posting the code being a tyro on this forum and being frustrated after many hours of research including in these pages. I did point out on the other post that It was a duplicate and it was not an attempt to attract extra attention by this 'cross posting'.

I had misunderstood the item on 'cross posting' when I studied the 'How to use this forum' earlier. I can only blame my ancient brain - as Homer Simpson says "when I learn something new it pushes something old out" but something old and stubborn in my brain probably prevented the new being learned!!.

This will not happen again from me.

You're advice about the board being based on the Atmega 1280 was spot on, my other mega boards are all 2560 so I made the traditional mistake of assumption and the printing on those chips is so small as to be nearly intelligible.

I have now learned a couple of new things, first that such a board exists despite it being discontinued by Arduino and secondly how to select processor when there is a choice.

Thanks you for your advice and help in solving my particular problem in such a knowledgeable way,

Terry

You're welcome. I'm glad to hear it's working now. Enjoy!
Per

Thanks,

Problem has been Resolved - unfortunately as this was not my topic originally I cannot edit the title to show resolution.

I have edited the title to indicated it's solved. Thanks for thinking of that. Most people don't bother, but it is helpful.