[SOLVED] Prolific - Win7 x64 troubles

Hello all,

Ok, so I have a clone, BTE robot using the Prolific drivers. (Learned that one after trying the FTDI drivers.) My system board is an MSI Z87-G65 using an Intel chip for USB (if that matters).

I have used both the Windows Update drivers and the Prolific drivers from their site: latest

I used to have it working a few months ago before re-installing my machine, so I have loaded a sketch to it already, and that still works (simple voltage measurement on the A0 pin and output to serial, and that comes through fine).

I've tried the loop back test as advised and when I had it first plugged in on my USB hub the data came back all corrupt. So I switched to direct port on the MB and now none of the data comes back through, I can see both TX and RX lights flashing on the board but no display. I have used both the Arduino serial monitor and Putty to test. I have also removed the CPU and put it back on, as I thought maybe contacts on the chip were dirty (I had grounded myself).

Recent changes; I got myself an ethernet shield for it and plugged that in when first connecting it to the new PC, since then I have unplugged it.

Strange phenomenon happens when I just try to use the Arduino software, its ok, until I go to the "Tools -> Port" menu and select the port... then the graphics of the program go all weird and glitchy and i can click on things, but its unusable really.

Don't really know where to go from here, or if its a driver or board issue.

PS. I am in IT, so feel free to tech-speak if you want.


EDIT: Ok, I just tried a different USB cable, and I can now get a good loop back (weird as it was kinda working before)... but... I am still getting strange occurrences in Arduino software with glitchy graphics and the inability to program the board with a different sketch.

I believe the usual culprit is the video driver. In any case, the issue has been discussed here a few times. I suspect a little searching will get you what you need... https://www.google.com/#q=site:forum.arduino.cc

Thanks for the reply.

I had originally searched for my first issue, and had really thought it was a driver thing.

But anyway, anyone who’s interested, my graphics issue went away after i turned off my FPS monitor (MSI afterburner).

Now only problem remains is getting it to program correctly. It’s still getting stuck uploading. Will continue my search.

Ok, to complete this for anyone else that searches... this was my error.

Even though it looks like the Uno, I had to select Duemilanove, and now that I look at it, its more like the Duemilanove in appearance. Just glad my board hadn't gotten stuffed.

I will mark this as solved for people in the future.