[Solved] Serial Port Unavailable on Windows 10 Pro x64

Hi I am having a problem with the Arduino web editor's serial monitor. It is saying that the serial port is unavailable but when I run the same code through the desktop app the serial monitor works perfectly fine. Does anyone know what can be causing this problem and how I can fix it? Below I have posted screenshots of what I am getting and the code I used.

Thank you,
Dean

1 Like

If you are running both softwares at the same time, one cannot read from the serial because the port is busy as used by the other software. Is this your case? Anyway the message sould be 'port busy' so thanks for your report, I'll check it! What OS and browser are you using?

I was not running the Arduino Desktop App nor did I have it installed when I first noticed the problem.

I am running Windows 10 Pro x64 on Google Chrome. I have not tried any other OS or browser yet but I plan on testing it on OSX later today and will also try another browser like firefox or safari.

EDIT: I was able to successfully access the Serial Monitor on OSX and safari, but I am still not able to access it on Windows 10, even after I tried reinstalling the extension.

1 Like

I'll create an issue and we'll investigate more, thanks for your report!

We have released a new version of the plugin that hopefully solves this problem, it should be auto-updated on your machine with version 1.1.52 (click on the tray icon of the plugin to see the version number). Let us know if this still happens!

1 Like

hey, I'm having the same issue. It uses to work on the web editor, I was doing some experiments and adding more complexity to my circuits and it stopped working. I tried to run the sketch on the initial circuit that use to work, but it doesn't work anymore. I have 1.1.94 version of the plugin, and I only used the web editor, not the IDE.

@ancaonuta

Please read this then add any missing details .

Please take a few moments to Learn and Use the Forum.

Hello, Welcome to the Arduino Forum. This guide explains how to get the best out of this forum. Please read and follow the instructions below. Being new here you might think this is having rules for the sake of rules, but that is not the case. If you don’t follow the guidelines all that happens is there is a long exchange of posts while we try to get you to tell us what we need in order to help you, which is frustrating for you and frustrating for us. The people who try to help with your project.

It will help you get the very best out of the forum in the future.

  • Mention if you are using AI generated code it is important information.
  • Your OS and version can be valuable information, please include it along with extra security you are using. Antivirus etc.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or CODE tags to add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks sterretje )
  • Add your sketch where applicable but please use CODE TAGS
  • Add a SCHEMATIC were needed even if it is hand drawn.
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Duplicate accounts are NOT allowed and any extra may be deleted.
  • Remember that the people trying to help cannot see your problem so give as much information as you can.

COMMON ISSUES

  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102 or FT232 VCP Drivers - FTDI
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.

COMPUTER RELATED

  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent

ARDUINO SPECIFIC BOARDS

  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO USB connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/ArduinoCreateAgent.app/Contents/MacOS/config.ini
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.

Language problem ?

Try a language closer to your native language:

Thanks to all those who helped and added to this list.

It is important to have details of what you have tried and how.

Sometimes a fix can be as simple as clearing a browsers CACHE.
Or a little more involved such as turning off any additional computer security to test.

Bob.