[SOLVED]Software reboot doesn't work - and so watchdog neither

If u try to remotely reboot linino (i.e. launch 'reboot' from shell), it will shutdown but never restart. This lead to a dangerous behaviour... Yun has watchdog enabled by default and if you try to force warchdog protection, it will reboot and so never start again... how to solve this problem?

Can you elaborate on this?

My Yun does reboot without any problems when i run reboot from the Serial Terminal http://arduino.cc/en/Tutorial/YunSerialTerminal

Yes. I work a lot with linux and raspberry pi, and usually when i have to reboot the system locally or remotely without unplug and plug power cable, i connect through ssh (with putty for example) and use the shell command "reboot". After this in some minutes the system will become available again. With Yun if i try to connect with ssh and give the reboot command it seems to work but the system wouldnt be visible to the network until i manually unplug and replug power cable. So we can say that sofware reset will not work. Because of this neither watchdog protection on linux side of Yun will work. Linino has hardware watchdog protection i.e. if a heartbeat to this device has not received in last 5 seconds, system will perform a reboot. This usually is usefull because if system hang will automatically reboot. But because of software reboot not working on Yun this will be bad, because you will have to manually unplug device in order to have it online again.

To test this behaviour you could try killing heartbeat generator in the shell with "killall -9 watchdog" command. In 5 seconds system will reboot but never boot again until hardware reset.

I too have never had an issue when rebooting from the serial terminal. Maybe this is specific to ssh? I'm out of ideas...

I tried "killall -9 watchdog" on my yun. The yun rebooted and connected to my wifi router (I'm not using wired with the yun) So yun did restart.

I have a network issue (not yun related) on my network which may be what you experience. Pinging to the yun did not work. The root cause: My wireless network router (EDIMAX WLAN AP webserver -don't buy one!!-) sometimes does serve wireless clients but does not allow for other network machines to connect to the wireless clients. Rebooting the wireless AP solves the issue. With this test I had to reboot my wireless AP to be able to connect to the yun.

Best regards Jantje

it was probabily a wifi-relatued issue due to my own wireless network.
With ethernet all is going ok.
Thanx all!