[solved] Soundsignal mit msgeq7 auslesen liefert "seltsame" Daten

Hallo, ich habe mir ein msgeq7 Breakoutboard angeschafft (https://i.ebayimg.com/images/g/XMoAAOSw0e9UwT9y/s-l300.jpg) und es wie in dem unteren Bild mit meinem Arduino Uno verkabelt. Folgenden Code aufgespielt:

 Website:   http://www.rheingoldheavy.com/msgeq7-arduino-tutorial-01-getting-started
 Datasheet: http://www.mix-sig.com/images/datasheets/MSGEQ7.pdf
 
 */
 
int strobePin  = 13;    // Strobe Pin on the MSGEQ7
int resetPin   = 12;    // Reset Pin on the MSGEQ7
int outPin     = A0;   // Output Pin on the MSGEQ7
int level[7];          // An array to hold the values from the 7 frequency bands
 
void setup() {
 
  Serial.begin (9600);
 
  // Define our pin modes
  pinMode      (strobePin, OUTPUT);
  pinMode      (resetPin,  OUTPUT);
  pinMode      (outPin,    INPUT);
 
  // Create an initial state for our pins
  digitalWrite (resetPin,  LOW);
  digitalWrite (strobePin, LOW);
  delay        (1);
 
  // Reset the MSGEQ7 as per the datasheet timing diagram
  digitalWrite (resetPin,  HIGH);
  delay        (1);
  digitalWrite (resetPin,  LOW);
  digitalWrite (strobePin, HIGH);
  delay        (1);
 
 
}
 
 
void loop() {
  
  // Cycle through each frequency band by pulsing the strobe.
  for (int i = 0; i < 7; i++) {
    digitalWrite       (strobePin, LOW);
    delayMicroseconds  (100);                    // Delay necessary due to timing diagram
    level[i] =         analogRead (outPin);
    digitalWrite       (strobePin, HIGH);
    delayMicroseconds  (100);                    // Delay necessary due to timing diagram  
  }
 
  for (int i = 0; i < 7; i++) {
    Serial.print       (level[i]);
    Serial.print       ("   ");
  }
 
  Serial.println ();  
 
}

Die Audioquelle ist mein mit dem Auxkabel verbundenes Handy. Wenn ich jetzt aber den Seriellen Monitor aufrufe gibt er mir nur seltsame Zeichen aus, mit denen ich nichts anfangen kann. Wenn ich diese Zeichen hier reinkopieren möchte sehen sie ganz anders aus, deshalb unten ein Bild.

Könnt ihr mir vielleicht sagen was diese Zeichen bedeuten, bzw. was ich korrigieren muss, damit das ganze läuft?

Das Zweite Bild ist anscheinend zu groß, deshalb hier ein Dropbox Link

Falsche Baudrate im Monitor, die muss mit der im Sketch übereinstimmen.

Nachtrag: man kann Bilder vor dem Upload verkleinern, solltest Du mal probieren :wink:
Und das Bild vom Modul ist zwar fein, aber nutzlos - wir sehen nicht, wo Du die Strippen am Uno dran hast.

Danke für die Tips, es war die Baudrate :slight_smile: