[Solved] STM32F103C8 uploading problem

Hello!

So after some experimentation with a Maple mini, i decide to pick up a bunch of "BluePill" cards.

Trying to upload the bootloader to it.

Using a FTDI "breakout"-board and the ST Flash Loader Demonstrator. I cannot get passed the first screen.

It says "No response from target".

I have set the boot jumper. I can see the green LED on the FTDI board blink briefly when i click "Next". I can also see with my scope that a signal is passed to the STM.

To be sure, i have checked the FTDI card with the scope and a standard terminal program, and it works great.

Now, the PC13 led on the stm-board itself blinks quite fast, 2.5Hz, i remember that my Maple blinked slower when it was "fresh". Is this an fault indication of some sort or normal?

It blinks the same no matter how the boot jumper is set.

Also, ive tried on two different PCs, one win10 and one win7.

Any ideas on this?

Thanks!

Did you press reset after selecting upload?

So after some more digging, i can see that the BOOT0 pin doesnt get 3.3V when using the jumper, its about 1v.
When feeding 3.3 directly to the boot0 chip-pin it enters bootmode.

The strange thing is that R3 is 100k, and measuring 100k all the way from the jumper to the pin…

Can it really be a bad resistor?