[SOLVED] TMRh20 Nrfl2401+ debugging

So I've been playing around with two arduino unos clones and a raspberry pi and a couple of the nrfl2401+ modules. I first tried maniacbugs but I could not get anything between the two arduino whatsoever. I tried adding caps, I tried different examples and nothing. So I swapped over to TMRh20's lib and got some chatter when going from arduino to RPI, but for the life of me cannot get the arduino to receive anything. I tried using the same TMRh20 library on two arduino to com with each other and still nothing. Swapped the NRF modules with the RPI one and nothing. But either arduino can for sure send msg to RPi and I verified that by arbitrarily choosing different msg values via the two different arduinos.

Now I'm stuck on how to debug this. Has anyone else come across this where the arduinos can send but can't receive?

Also, I'm super new to arduino, but have some programming background.

Nevermind, seems like faulty or loose pins on the cheap arduino uno clones I got. I switched over to the Arduino Nano clone and that worked instantly.