[solved] Trying to restore Arduino UNO after flashing HIDUINO

Hi folks,

Yesterday I flashed the HIDUINO firmware to the 16u2 on the UNO via ISP, and today I'm trying to get it back to stock firmware. I've tried flashing the usbserial hex from the HIDUINO site, as well as the UNO-dfu_and_usbserial_combined.hex from arduino. No matter which firmware I upload, I always get "programmer is not responding" when trying to flash using the stock firmware. I've successfully flashed sketches with the ISP, but can't seem to do it through usbserial.

The UNO seems to enumerate properly with both firmwares. It just doesn't seem to respond to usbserial commands.

Any thoughts?

Here's the dump from the verbose upload information:

macbookpro:tmp matthew$ /Volumes/Extended/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Volumes/Extended/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/tty.usbmodemfd121 -b115200 -D -Uflash:w:/var/folders/hh/g9x6v0cj6fs6zdj0dmrb047h0000gp/T/build6543603751105679663.tmp/Blink.cpp.hex:i

avrdude: Version 5.11, compiled on Sep  2 2011 at 18:52:52
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Volumes/Extended/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/matthew/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/tty.usbmodemfd121
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

I managed to fix it just after posting this. The problem was that the UNO's bootloader was corrupt - likely as part of my HIDUINO experimentation. I used the ISP to reflash the main UNO chip through the Arduino IDE. After that, it worked great.