[solved]Uno with attiny85: avrdude: stk500_getsync(): not in sync: resp=0x00

follwing steps from high-low tech here. http://hlt.media.mit.edu/?p=1706

It gives me an error : avrdude: stk500_getsync(): not in sync: resp=0x00

I have tried it more than 5 times, changing jumping wires and the attiny85. I even dowloaded older version 1.0.1. I have googled and read many pages, but can’t find any solution. Can anyone help?

=================
somehow, I need to upload an arduinoisp sketch to the uno board before I can use it as an ISP to upload the code to the attiny chip. I am very new to arduino, and I missed this step from the high-low tech tutorial.

It gives me an error : avrdude: stk500_getsync(): not in sync: resp=0x00

When you do what?

What type of ICSP programmer are you using?

when I upload a simple blinking led sketch.

I have no idea what a ICSP programmer is, but I am sure I have picked “Arduino as ISP”, as that tutorial shown.

hiduino:
What type of ICSP programmer are you using?

Which board do you have selected when you try to upload the blink sketch?

[quote author=Coding Badly link=topic=163216.msg1219352#msg1219352 date=1367138733]

Which board do you have selected when you try to upload the blink sketch? [/quote]

there are only 3 options for attiny85, and I selected all of them with the same error.

This error indicates that the ide is not communicating correctly with the board. Please make sure you have the correct drivers installed and have the correct COM port selected. This is really the only help I can give you as this is a weird way of doing this as I have only experimented with hooking up the TX and RX pins and transferring data through that. I could also suggest that you have the needed cap value and you have it in the correct way (white line to gnd) and that you have the correct code for your ide version.

Quote from website:

Note for Arduino 1.0: you need to make a small change to the ArduinoISP sketch before uploading it. Find the line in the heartbeat() function that says “delay(40);” and change it to “delay(20);”.

Also make sure that when you are programming the isp, you have the right arduino board when you upload the sketch

-Luke

It's depressing. what kind of driver do I need? It's fine uploading to the uno board itself, and I have only one com port, so it can't be wrong. I am pretty familiar with electronic part and I am sure I hook everything up right. It seems to me that attiny tutorial from high-low tech is outdated, and I can't find anything new. anyway, thanks for the help.

l3gendluk3: This error indicates that the ide is not communicating correctly with the board. Please make sure you have the correct drivers installed and have the correct COM port selected. This is really the only help I can give you as this is a weird way of doing this as I have only experimented with hooking up the TX and RX pins and transferring data through that. I could also suggest that you have the needed cap value and you have it in the correct way (white line to gnd) and that you have the correct code for your ide version.

Quote from website:

Note for Arduino 1.0: you need to make a small change to the ArduinoISP sketch before uploading it. Find the line in the heartbeat() function that says “delay(40);” and change it to “delay(20);”.

Also make sure that when you are programming the isp, you have the right arduino board when you upload the sketch

-Luke

arduinomagbit,

You’ve re-titled this subject Solved, but it isn’t.

Do I have it right that

  • You’ve Opened the “Arduino as ISP” sketch (Example) and made the modification noted previously
  • uploaded that “Arduino as ISP” to your Uno
    Then
  • You’ve opened your Blink sketch,
  • chosen ATtiny85(w/ Arduino as ISP)
  • attempted Uploading and… failed

?
Resolutions can take time - Don’t give up now.

[quote author=Runaway Pancake link=topic=163216.msg1219869#msg1219869 date=1367166206] arduinomagbit,

You've re-titled this subject [u]Solved[/u], but it isn't.

Do I have it right that

  • You've Opened the "Arduino as ISP" sketch (Example) and made the modification noted previously
  • uploaded that "Arduino as ISP" to your Uno Then
  • You've opened your Blink sketch,
  • chosen ATtiny85(w/ Arduino as ISP)
  • attempted Uploading and.. failed

? Resolutions can take time - Don't give up now. [/quote]

No, It didn't fail. It works!!! I have not modified anything. I am so excited now what I can do with this tiny chips.

Glad you have that set right, though I gathered otherwise from your previous post. OK. Good Deal then.

They are a handy option for the Magic Bag of Tricks. And get a Proto-Shield and build it up on that, to have a fixture at the ready. http://arduino.cc/forum/index.php/topic,87229.msg658829.html#msg658829

@Ruanway Pancake I don't know how long this has been here, but it worked for me. I'm using Arduino 2.2, and none of the tutorials I've read mentioned that you should first upload the ArduinoISP sketch in order to use it as an ISP. I'm very excited about my ATtiny, thanks a lot.