[SOLVED] Upload Problem / pin 1 & 0

Hello.

I tried to upload a new program to my Arduino Diecimila while I had connected pin 0 and 1 to my computer speakers. I didn't know that this may damage the board, I read it after I got the problem.

Everything was working just great before that, so there is no problem with choosing the right COM port and so on...

In case I need to burn a new bootloader, is there any way I can do that with my AVR Dragon? It has JTAG and ISP interfaces.

EDIT: The L led light blinks constantly!

This is the error message I get:

Binary sketch size: 1396 bytes (of a 14336 byte maximum)

C:\Program Files\arduino\hardware/tools/avr/bin/avrdude -CC:\Program Files\arduino\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -pm168 -cstk500v1 -P\\.\COM8 -b19200 -D -Uflash:w:C:\Program Files\arduino\examples\Analog\Fading\applet\Fading.hex:i 



avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "C:\Program Files\arduino\hardware/tools/avr/etc/avrdude.conf"

         Using Port            : \\.\COM8
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 19200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20] 
avrdude: Recv: 
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done.  Thank you.

Solved?

What happened? What did you do to solve?

Guys I must be the best noob in the world!

I burned the .hex bootloader file to the Arduino by using my AVR Dragon programmer and AVR Studio and everything is now working ;) :D

The reason I used AVR studio was that the Arduino program doesn't support AVR Dragon.

So, if anybody needs more information on how I connected AVR Dragon with Arduino I will be happy to write an article about that.

/Dimme