[SOLVED] Uploading: avrdude: ser_open(): can't open device "\\.\COM3":

Hi. As of a couple of days ago, I am no longer to upload s/w from the IDE to any of my Arduino boards. I have a Nano (built in USB) and also a homebrew built with an Uno compatible boot loader + external FTDI adapter. Both were working - literally downloaded code one night with no problems, then it failed the next morning. The Arduino board is functioning since I can see that it is running the old version of the code. Have tried downloading simple "blink" code, with no change so don't think it is the source code.

I am running Windows 8.1, 64 bit with IDE 1.6.1. I updated to IDE 1.6.3 with no change. Multiple PC reboots. I have tried deleting and reloading device drivers with no change. In devmgr, I see a single device under "Ports (COM & LPT)", named "USB Serial Port (COM3)" for the Uno bootloader. I enabled the option to see hidden devices in the device manager, and don't see any additional ports. Also used the Microsoft USB tree utility and don't see anything strange. The board and serial port are set correctly. Have tried 2 different cables. The Uno bootloader Arduino supports autoreset, and I have also tried various manual reset permutations with no change. There seems to be a thread about a missing usbser.sys file - I can see it in Windows\System32\Drivers.

Verbose upload details are below. Thanks in advance for your help.

[update] - solved it myself - a microsoft mouse driver was also using serial USB port. I hadnt used the mouse for months and not sure why it decided to start causing a conflict recently ... For anyone troubleshooting similar issue, note that the mouse driver wasnt visible in the "PORTS" section of devmgr when viewing "devices by type" - had to switch to "devices by connection" to see it


Arduino: 1.6.3 (Windows 8.1), Board: "Arduino Uno"

Build options changed, rebuilding all

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.

C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\Mark\AppData\Local\Temp\build5681242342844022799.tmp/Blink.cpp.hex:i

avrdude: Version 6.0.1, compiled on Mar 30 2015 at 14:56:06

Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : COM3

Using Programmer : arduino

Overriding Baud Rate : 115200

avrdude: ser_open(): can't open device "\.\COM3": Access is denied.

avrdude done. Thank you.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" enabled in File > Preferences.

A couple of other details. When I connect, disconnect or reset the boards the PC makes the windows attach/detach sounds normally. Also the ports in the IDE “port” menu show up normally - they are not greyed out or anything, and the port numbers match between the IDE and Windows devmgr.

Tried updating Java to latest version with no improvement. Serial port loopback per the instructions on this site and using the IDE serial port monitor did not work, and in fact hung the IDE.

In desperation I tried going back to IDE 1.0.6 ... and it is working again. I would still welcome any ideas on what this could be. IDE 1.6.1 was working fine at one point and I would like to upgrade again. Thanks.