[solved] Web editor timeout when downloading.

PC: Ubuntu 18.04 LTS
Browser: Firefox for Ubuntu 72.0.1 (64 bits)
Board:Arduino Duemilanove connected on /dev/ttyUSB0
Arduino Agent version 1.1.101-318de37

I’m using Arduino boards with installed IDE for long time.
I’m trying the Web editor for the first time using standard sketch example BlinkWithoutDelay. On the installed IDE I download to the board all Ok , but with the same computer/usbPort/cable/board, using the Web editor , the sketch compile, begin to load, (I see the comm traffic on the board leds), but

[/dev/ttyUSB0] → [/dev/ttyUSB0]
[/dev/ttyUSB0] → [/dev/ttyUSB0]
[/dev/ttyUSB0]
Wait for the port to reappear
[/dev/ttyUSB0] → [/dev/ttyUSB0]
timeout
Flashing with command:/home/grelot/.arduino-create/arduino/bossac/1.6.1-arduino/bossac -i -d --port=ttyUSB0 -U true -e -w -b /tmp/arduino-create-agent474841813/sketch_may31a.bin -R
Set binary mode
Send auto-baud
Set binary mode
No device found on ttyUSB0

And it end with the ‘No device found on ttyUSB0’ error message and the sketch not download. The board detected in the browser is Arduino Due Native USB port at /dev/ttyUSB0. Not the Duemilanove ! I insist on that all is OK on the 1.8.10 version of the installed Arduino IDE.

Help please !

dubser123:
The board detected in the browser is Arduino Due Native USB port at /dev/ttyUSB0. Not the Duemilanove !

This is very strange. I wouldn't expect the Duemilanove board to be detected at all, just show up as "Board at ttyUSB0", but I don't own a Duemilanove so I can't test it out.

The Due board selection is definitely the cause of the error. You can fix it like this:

  • Click on the board menu.
  • Click "Select Other Board & Port".
  • From the "Boards" menu, select "Arduino Duemilanove".
  • From the "Ports" menu, select "ttyUSB0".
  • Click the "OK" button.
  • Try uploading again.

dubser123:
I insist on that all is OK on the 1.8.10 version of the installed Arduino IDE.

In the Arduino IDE's Tools > Port menu, do you see: "ttyUSB0 (Arduino Due (Native USB Port))"? Or does it just say "ttyUSB0"?

On the installed IDE I only have ttyUSB0 choice, the Arduino Due (Native USB Port) is not offered, and this seems Ok for the download occur without error.

OK, that shows that the manufacture of the Duemilanove didn't somehow accidentally program its USB to TTL serial adapter chip with the VID/PID of the Due.

Did you try setting the Arduino Web Editor to Duemilanove? Is it working now?

Click on the board menu.
Click "Select Other Board & Port".
From the "Boards" menu, select "Arduino Duemilanove".
From the "Ports" menu, select "ttyUSB0".
Click the "OK" button.
Try uploading again.

Left of the board select window a red X appear near to the "Arduino Duemilanove" selection and the download give the message 'Error uploading check if selected board is available'. No comm visible on the board.

Previously when the selection was 'Board as Arduino due (Native USB port) at dev/ttyUSB0' no red X appear and the sketck compile before trying to download ( confim by trafic light on board) but with a timout termination.

I take screen shot to illustrate but sorry did not find the way to insert in the forum text !

Thanks for your time.

Serge

Was dev/ttyUSB0 shown as an option in the "Ports" menu? Did you select it?

dubser123:
I take screen shot to illustrate but sorry did not find the way to insert in the forum text !

If it's just a picture of the red X next to Duemilanove in the Board menu, I know what it looks like. But you might like to know how to post images on the forum anyway. If you click the "Reply" button, you'll see a link "Attachments and other settings" that will allow you to attach an image. Many forum members won't bother to download attached images, so it's best if you attach and then embed the attached image in your post. There is a guide to doing that here:

Was dev/ttyUSB0 shown as an option in the "Ports" menu? Did you select it?

You are true , as the dev/ttyUSB0 was the only one option suggested I supposed it was selected by default. Now I select it and now everything is OK it download.

Tkanks a lot for your help.

Please mark as Solved.

You’re welcome. I’m glad to hear it’s working now. Enjoy!
Per