<SOLVED> Wemos D1 Pro comile error - Win10

Hi all,

Just received 2 Wemos D1 Pro boards. Downloaded and installed the ESP8266 JSON file.
Also installed the OneWire library, and DallasTemperature library. Both from : http://randomnerdtutorials.com/esp8266-ds18b20-temperature-sensor-web-server-with-arduino-ide/

Then using the code on the web site, using my own WiFi login details, programmed the first board. Everything worked well, recording temperature on a mini website. Actually, I tried a few different sketches, including WiFiscan etc. All worked okay.

Then i went to program the same Temperature sketch into the 2nd D1Pro. However, now it doesn’t work.
Sat for over 10 minutes before I realised that it wasn’t going to work.
Tried using the 1st D1 board again, but did not work either.

Turned on Verbose logging. Please see attached. This is the complete log.

I have reinstalled the IDE, but no luck. I cannot see what is wrong in the log.

So people, what has happened? And if more info is required, just ask.

If I’ve done something wrong please advise.

Arduino Compile error - 2007201.pdf (36.7 KB)

Forgot to mention that I installed v1.8.3, no luck. Now trying v1.6.10. Still no go. I did find that v1.8.3 did not install, rather unpacked and ran from unpack folder.

Had forgotten that new AntiVirus software was installed. Removed, now works okay. Now to figure out how to dd to whitelist.