[SOLVED] WiFi works on channel 1 and 2 only

I'm trying to run WiFiNINA library WiFiPing example.
My router is Netgear WNDR3400, and its 2.4G WiFi is set to 802.11g mode, WPA2-AES encryption, and normally on channel 11.

However, Serial Monitor window prompts dozens of:

Attempting to connect to WPA SSID: +

(the plus sign is my SSID) and the WiFi would not connect.

I tried changing settings on the WiFi router. It seems that the ublox can connect to my WiFi only if the router is set to channel 1 or channel 2. Any channel 3 or above does not work (I tested 3, 6, 11).

I tried the ScanNetworksAdvanced example. It is able to find my network on channel 11.
I used WiFi Analyzer app on an Android phone, and I can confirm that channel 11 is less crowded than channel 1 at my environment.

Does anyone else have the same issue?

Hello yoursunny,

Have you tried with the last change in WiFiNINA Library ?

failure to connect to AP with WAP · Issue #20 · arduino-libraries/WiFiNINA · GitHub

Yes, master branch works!
I didn't know that "library manager" would install a "release". I thought it's just a git clone...