[SOLVED] Windows 10 not recognising MKR 1010, Nano 33 IoT, or Nano 33 BLE

I used the double-tap to place into boot loader mode and uploaded a clean sketch and all was fixed - cant remember the post or poster who provided that insight - but THANK YOU!

Still perplexed about why the other new boards though… had the same issue though. Also, reloaded the last sketch I was working on before the issue and it starte ddoing the same thing so I started eliminating - I got to the point where the issue was in the “Serial” instructions and when I reduced baud ot 9600 everything worked fine… weird

=================================================

Hi There!

I am a newbie to Arduino but I have a coding background. I have bought a number of boards and most recently I’ve been working on the MKR 1010 (about 3 days old) which was working perfectly loading sketches and running… until it didn’t.

I removed the Arduino IDE and drivers then reinstalled but still couldn’t get Windows to recognise the board. So I tried:

  • Using cloud IDE
  • Changing Cables
  • Changing ports
  • Changing laptops
  • Changing to a new (straight out of the box) Nano 33 IoT - still no luck
  • Changing to a new (straight out of the box) Nano 33 BLE - still no luck
  • I then tried a genuine Uno and it worked fine so I tried the others again just in case - still no good.
  • Manually loading drivers
  • Reinstalling IDE with old version (1.7 and 1.6) of SAMD board drivers
  • I’m currently running recovery on my Windows laptop (retain files & settings but remove all apps), but I’m not holding out much hope. —> UPDATE - recovery didn’t fix the issue and I’m loathed to take it back to a clean imagfe unless I have to.

Everything seems to be pointing to a board issue but I’ve tried brand new 3 3.3v boards all with no luck yet a 5v board (Uno) works perfectly. All boards are genuineand the MKR 1010 has only been running LEDs so not sure where to go from here.

Any help would be really appreciated as I’ve spent 3 days trying to resolve.

Many thanks for your interest.

S