[SOLVED] Windows 11 anomaly with brownout

This has only happened since I moved to Win 11.
I upload a sketch to an ESP32 Devkit V1 and every time I try to run it I get a Brownout error loop. The brownout occurs when I try to open Bluetooth.
It is not a power supply problem with the USB port because if I use a charging only USB cable the sketch runs as expected.
Even if the Arduino IDE is closed the data cable won't run the sketch. So I don't think it is an Arduino IDE problem. It appears as if Windows 11 is causing the problem. Task Manager shows no abnormal activity.
I'm wondering what Windows object could be muddying the waters. Has anyone any idea what I can look for to give some diagnostics?

I have tried contacting Window 11 support. That was utterly futile - they only solve Windows errors so contact the hardware vendor. The fact that Arduino IDE and ESP32 work perfectly on Win 10 but not Win 11 suggests to me there is an issue with Win 11. But "Microsoft locuta; causa finita est".

I can upload sketches to the ESP32 but can't monitor or debug them using serial monitor because it simply loops on the bluetooth brownout message. Life wasn't meant to be easy.

PS. Wemos D1 mini works fine but it doesn't have bluetooth of course.

After a lot more analysis the problem appears to be with the MSI B550M PRO-VDH WiFi AM4 motherboard. Even when I go into the BIOS setup I still get the same problem. I've tried disabling INTEL WiFi but even that makes no difference.

Have you tried to disable that WiFi device in Windows device manager?

This is the only suggestion that I can make.

Yes, I even tried that.

I'm beginning to think I will have to use an old Ubuntu PC to do my Arduino debugging.

There is some stuff google finds on this , not sure if it helps you ..eg :slight_smile:

I did read a few weeks back that there is a problem with Windows 11 and AMD CPU’s. Possibly contributing to your issue perhaps? Only a complete guess though.

Apparently there is a patch now, which can be installed through windows update.

Likely not the cause of your issue, but you never know.

Many thanks for the replies. I am 99% certain Windows 11 is not the problem; even if I go into the BIOS setup when Windows isn't even loaded and plug the ESP32 into a USB port it suffers the same problem (I flash the ESP32 LED immediately after the Bluetooth.begin command and it never gets that far).
I'm also 99% sure the problem is with the new MSI Motherboard which has on-board Bluetooth. The MSI forums report a lot of issues with the B550m PRO-VDH WiFi AM4 Motherboard; I have posted a thread there and received a few helpful hints but have not had any luck.
My wife has an old Ubuntu PC so until I get a resolution I will load Arduino on her PC and debug there.
In the meantime I would advise Arduino IDE users to avoid this motherboard.

No worries.

You threw me when you said “This only happened since you moved to Windows 11”, which inferred it used to work in the past on your main board.

I have just done a swag of updates to Windows 11 and its many drivers. I can upload without problem and use serial monitor with ESP32-dev-kit 1. :grinning:

I still have an outstanding problem with my ESP32-Cam and serial monitor. But I will start a new thread on that. I will mark this one as solved; though I don't know for sure what fixed the problem I first encountered.
Many thanks to all who replied.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.