[Solved] Windows 7 Code 28 and "Unknown Device" on "Getting Started"

I'm not going to going into every detail, just to say that following the "Getting Started on Windows" led me up a blind alley (Windows 7) involving No ports showing in device manager at stage 4 "Unknown Device" and "Code 28" on device lists "Browse my computer" could not locate the .INF file and lots of other stuff. Even tried a different USB lead, that didn't work Didn't try throwing it out of window, it's p'ing down out there! :0 (NB the power and "L" lights worked as described)

My start point was #2 "download the Arduino Environment", unzipped the downloaded file and made sure the folders and files were all in place, as per instructions.

The cure - I removed the unzipped IDE and started again, but this time I executed the Windows installer at stage 2, which I had also downloaded.

Result - files all unzipped, installation completed.

Stage 3 resulted in the Windows driver installation succeeding, not failing! Ports now showing in device manager - well, one anyway, the one with the Arduino on it (COM3). Followed instructions to update driver software, and got message "Windows has determined your software driver is up to date".

Tried making changes to the Blink example and uploading them, all worked OK.

So - use the supplied Windows installer program, and ignore stage 4, and all is well. So far :)

I hope this helps - Dick