Some Basic stuff

I am running Arduino 1.6.3 and it didn’t have the DUE available under Tools Boards. Fixed this by loading it under Board Manager.

When I now compile and try to load a program it compiles fine but when loading it says No device found on Com 12.

Now Com 12 according to system manager is fine - it is where the PC allocated the DUE device and says under Ports - Arduino Due Programming Port (COM 12).

So why the error?

Also which programmer should I use on the list? I have AVR ISP selected.

Read the "Getting Started" info - extra (non-AVR) cores need to be installed expicitly
using the board manager:

But it seems you've done this.

You don't use a programmer for the Due, the bootloader is permanent in
ROM, you just upload sketches.

Use the programming port unless you have a reason not to, I would say.

I suspect a Windows-specific issue here, I can't help with that.

Yes I installed the core separately as you said. If it's a windows problem then I'm stuffed! Yes I'm using the programming port. I wonder if it's permissions?

Ok I found this on a FORUM, not good but it works. There is a bug in the firmware somewhere


SOLVED

You need to do three very simple things after connecting the Programming port with the computer/laptop :

  1. Press the erase button for about 3 seconds.
    2.Press the reset button.
  2. Upload the code.

You need to do this every time you want to upload a sketch. Everything else will hopefully work fine after that.

P.s : I think the problem is the board is not erasing the data pre-written or something.
And it is all done. Tried , tested , worked. Cheers !


I am using the native USB which is faster anyway. I found when you reset that the COM port changes - look on Device Manager! It only changes once - for me from COM 16 to COM 15 and then it started working without the reset thing. So I am ok so far.