Some NRF24L01 modules not working

Hi. Dear,
I tried to do wifi communication as follow site.
https://www.brainy-bits.com/how-to-use-the-nrf24l01-2-4ghz-wireless-module/#comment-151
I did it. But I have a problem. I used 3 types of modules. (Attached)
A - NRF24L01+PA+LNA with Antenna
B - Black one (No antenna)
C - Green one (No antenna)

When I use A as Tx and B as Rx, It is working. When I use all other combination(B as Tx and A as Rx,C-A, A-B,B-B,…), it did not work.

What is the wrong.

Please help.

C.jpg

Have a look at this Simple nRF24L01+ Tutorial.

...R

Dear Robin2, I tried it. But It were this messages.

SimpleTx Starting Data Sent Message 0 Tx failed Data Sent Message 0 Tx failed Data Sent Message 0 Tx failed Data Sent Message 0 Tx failed ...

And this on the receiver:

SimpleRx Starting Data received Message 0 Data received Message 0 Data received Message 0 Data received Message 0

No errors other wise. Please help.

Hemantha

How frequent were the messages on the RX device? They should be about 1 per second. If they are coming much faster then it usually means incorrect wiring between the Arduino and its nRF24.

Have you tried the connection-test program which IIRC is in Reply #29?

...R

Dear Robin2,

Yes,the messages came about 1 per second.

I didn't try the connection-test program.

I am a newer for this section. Can you help me to test connection.

I tried again as follow site. https://www.brainy-bits.com/how-to-use-the-nrf24l01-2-4ghz-wireless-module/#comment-151

I used Arduino Uno and NanoV3. A - NRF24L01+PA+LNA with Antenna B - Black one (No antenna) C - Green one (No antenna)

When I use A with Nano, It is working(Transmitting and receiving). The Nano doesn't work with other modules. (This example didn't work anytime)

Thanks Hemantha

plaahemantha: I didn't try the connection-test program.

Please do so and report back exactly what happened.

...R