Souci avec carte Arduino Nano compatible

Bonjour à tous, je viens de faire l'acquisition de la carte AZ-DELIVERY Nano (ATmega328P)qui est normalement 100% compatible Arduino Nano.

Alors autant vous avertir, je suis un véritable néophyte et je m'en excuse si certaines de mes questions peuvent sembler idiotes, malgré mes nombreuses recherche.

Après avoir installé sous windows le logiciel Arduino 1.8.8, j'ai connecté la carte sur un port USB. La led pow est rouge et reste fixe. La led L est rouge et clignote.

Lorsque que je lance le programme, je ne savais pas par quoi commencer, je suis donc aller dans outils/ype de carte et j'ai sélectionné l'Arduino Nano, et ensuite le port com (com5) qui m’ait été proposé. mais rien ne se passe à part des erreurs :

Récupérer les informations de la carte m'affiche le msg suivant :

BN: Carte inconnue
VID: 1A86
PID: 7523
SN: Envoyez un croquis pour l'obtenir

j'ai ensuite récupérer un bout de code normalement fonctionnel et je l'ai envoyer vers l'"arduino". un message est apparu au bout d'1mn environ :

Le croquis utilise 2972 octets (9%) de l'espace de stockage de programmes. Le maximum est de 30720 octets.
Les variables globales utilisent 127 octets (6%) de mémoire dynamique, ce qui laisse 1921 octets pour les variables locales. Le maximum est de 2048 octets.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xbf
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xbf
Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.

Du coup je galère depuis presque 6h dessus, j'en appel votre aide si vous pensez pourvoir m'aider.

En vous remerciant.

Dans la doc ils disent

ATmega328P chipset with 16 MHz clock speed and 32 KB flash memory (incl. 2 KB for the bootloader); easy PC connection via CH340G USB converter.

Il vous faut installer un driver USB pour CH340

Attention à ne pas télécharger un driver de source louche qui inclurait aussi un virus... (j’utilise pas Windows donc je n’ai pas de recommendation particulière pour le driver)

Je te suggère le tuto sur les problèmes de téléchargement

Avec une NANO, il y a de fortes chances pour qu'il faille choisir "ATmega328P (OldBootloader) dans le menu Outils.

@+

Ah yes, déjà un bon début de réponse de votre part. je vais testé ça ce soir ! et je ferai une remonté.

Merci !

De retour. Donc en effet en passant par "ATmega328P (OldBootloader)" tout fonctionne correctement pour le téléversement. Hormis la récupération d'info de la carte ou il y a toujours un popup qui me dit qu'il ne reconnait* pas la carte.

*Peut être à cause du fait qu'il m'a été impossible d'installer les pilotes CH340G comme indiqué plus haut. windows m’envoie paitre, avec un joli message refusant l'installation.

Mais bon, l'essentiel c'est que cela fonctionne. Grand merci !

Si le téléversement fonctionne, c'est que le driver est installé, sinon, aucune chance.