sounds stupid but is there some final step I am missing?

When you are satisfied with the code you've written and whatever it does? Another step or final step after flashigng the code? It does exactly what I want after it starts running on my ESP-32, then I turn it off and I get this error while using battery power. But it has more to do with loosing that first state before it gets disconnected.

here's the error

Board at /dev/cu.SLAB_USBtoUART is not available

I get it when Arduoino IDE is open and I try to go to the serial monitor. Also that board is no longer an option in boards....

here the MIDI

Any help would be much appreciated!

projector_bach:
When you are satisfied with the code you've written and whatever it does? Another step or final step after flashing the code? It does exactly what I want after it starts running on my ESP-32, then I turn it off and I get this error while using battery power. But it has more to do with loosing that first state before it gets disconnected.

here's the error

Board at /dev/cu.SLAB_USBtoUART is not available

I get it when Arduoino IDE is open and I try to go to the serial monitor. Also that board is no longer an option in boards....

here the MIDI

Any help would be much appreciated!

I feel like my project is still in a development state. Even though a verify and compile (which I think means pushing the code to the arduino board), I still feel like maybe I am asking it to "run once" as apposed to "run every time you turn on." That or I am wondering if anyone else gets this error. I am trying to not even look for an error. I want to cut ties with the python IDE. That is where I think I am unclear. I don't want to have to open the app every time I want to run the code. I want the code to run every time I power on... Anyone kinda understand. I know this is confusing as I am confused. ha
the file I am running or opening or compiling to my exp-32 is here:

projector_bach:
Even though a verify and compile (which I think means pushing the code to the arduino board)

What IDE are you using? The standard one has "Verify/Compile" which just compiles the code but doesn't send it anywhere and it has "Upload" which is the option that loads the code to the board.

Steve