Sparkfun FTDI Basic and boards not showing up in Tools/port on Mac Catalina

Hello,

I have tried about 5 different "fixes" now and nothing seems to help my Sparkfun FTDI Basic show up in the Tools/port.

I have tried using the FTDI breakout with a few different Arduino Mini Pro clones and a lilypad but nothing shows up.

I have tried using a different USB cable but nothing shows up.

I have restarted my mac no less than 12 times but nothing shows up.

I have installed the FTDI drivers from the FTDI site to no avail.

There was one tutorial that mentioned moving some files from /Library/Extensions/ to /System/Library/Extensions/ but I was not able to do so because the latter directory will not allow me to drag/drop files into it.

The files in /Library/Extensions/ are:

And the files in /System/Library/Extensions/ are:

Thanks for any help anyone can give!!

(deleted)

The Sparkfun FTDI board is NOT an Arduino!!

I do know this. BUT you need to use the Sparkfun FTDI(or something similar) to connect to Arduino clones that do not have a USB on them, like the boards I mentioned in my OP. I just assumed that people would be able to figure out that I used the FTDI, directly connected to the Arduino clones, to try to program them with the Arduino IDE. I suppose I need to state it more clearly next time.

Just in case anyone else is going to mention it, I did make sure that the connections were rx --> tx. All the boards lit up so I know at least power was getting to them.

(deleted)

The FTDI will just show up as a Port: Com on a PC. It doesn't care what's on the other side of it until that part starts talking.
FTDIport.JPG

FTDIport.JPG

Does Sparkfuns forum/customer support have directions for installing the drivers for your OS?

Yes. I followed these instructions for the FTDI Basic
It did not work.

What about the FTDI website.

Yes-as I stated in OP:

I have installed the FTDI drivers from the FTDI site to no avail.

It did not work.

I'm not sure what you mean by 'BUT you need to use the Sparkfun FTDI(or something similar) to connect to Arduino clones that do not have a USB on them'. I use FTDI's to do mapping for engine controllers, but would not expect to get help from FORD or similar company because I can connect it to their product!

I don't know what you are asking here. The Arduino Pro Mini connects via a 6-pin header to the Sparkfun FTDI Basic breakout board because there is no USB on the mini itself. You need the FTDI to facilitate communication between the board and the computer via USB.

(deleted)

I use CP based USB->TTL converters, as well as my Arduino, with a jumper between 5V and RESET.

So what you're telling me is that you use some sort of device to facilitate communication between your Arduino and your computer? I didn't realize I was so far off by claiming that I needed some sort of a device to facilitate communication between my Arduino and my computer. My bad.

At any rate, I came here looking for helpful advice, not to argue with people. Perhaps someone else reading this post has some ideas?

I think she might be referring to a CP2102, which is another type of USB/Serial adapter


PL2303 is another type.

The only Apple product I have is an iPad, sorry I can't help with your Mac problem.

(deleted)

WOW.... "ADJUST YOUR ATTITUDE"?

You are the wrong man for the job... I understand that people struggle with a whole lot of issues connecting arduino's to Macs and your inability to communicate civilly puts you way out of line.

There are people wanting to advance their knowledge and running into issues and the best you can do is insult them?

(deleted)

The Sparkfun page you referenced was for OS X 10.5.

This MIGHT fix it:

Personally, I gave up on Catalina after being tortured with broken apps for three days. I had to revert to El Capitan from a network restore to get rid of that turd.

Apple are moving from what are called Kernel Extentions (.kexts) to what are called Driver Extensions (.dexts) for the implementation of drivers starting in macOS Catalina (10.15). Currently .kexts are still supported in macOS Catalina, however after the beta release they issued an update which stopped our driver from loading. This update required our driver (FTDIUSBSerialDriver.kext) to be re-signed and notarized, we completed this process with an updated Apple Developer ID (as they lapse every two years). Unfortunately when Apple issued our new Developer ID to re-sign and notarize the driver package they did so without the .kext support option enabled (as .kexts are being deprecated it is no longer automatically included). This is why there is a code signature issue with our driver, currently we are waiting on Apple issuing us with the correct Developer ID to be able to sign .kexts for macOS Catalina.

As such our current VCP driver available on the website has a signature issue and wont load. However if the device you are using implements a default FTDI VID/PID combination it should be picked up by the inbuilt AppleUSBFTDI.dext driver and present accordingly in the ‘/dev’ folder on your system in the following form:

/dev/cu.usbserial-xxxxxxxx

/dev/tty.usbserial-xxxxxxxx

Thanks, WattsThat, this was super helpful! I was hoping that this was not going to be an OS issue. I use a work computer and am not able to revert back to a previous OS. I agree that this has been a very frustrating change made by Apple. Got any advice for an inexpensive PC I could use to program microprocessors with?

(deleted)