Sparkfun Pro micro sketch upload fail, bricked, usbmodem

I’m using a sparkfun pro micro for a few days now, i uploaded many sketches to it. Today after one upload i maybe stopped the upload mid-time (pressing upload while it was uploading) or i don’t know what happend but now i’m unable to upload any sketch to it. It is the 5v modell. I tried with different usb cables and different usb port on the computer. When i plug it in i get a port for a few seconds named “usbmodem” but after that the port disappears. I tried the reset pin grounding twice method but i only get the same “usbmodem” port after that too. I attached the full log in a txt file.

Few rows of it:
avrdude: ser_drain(): read error: Device not configured
avrdude: ser_drain(): read error: Device not configured
avrdude: ser_send(): write error: Device not configured
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding

avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: ser_drain(): read error: Device not configured
avrdude: ser_send(): write error: Device not configured
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: ser_send(): write error: Device not configured
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: ser_send(): write error: Device not configured
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
Found programmer: Id = “”; type =
Software Version = .; Hardware Version = .
avrdude: ser_send(): write error: Device not configured
a kiválasztott soros port Software Version = .; Hardware Version = .
nem létezik vagy az alaplap nincs csatlakoztatva
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: ser_send(): write error: Device not configured
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: buffered memory access not supported. Maybe it isn’t
a butterfly/AVR109 but a AVR910 device?
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude: ser_send(): write error: Device not configured
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: leave prog mode
avrdude: ser_send(): write error: Device not configured
avrdude: ser_recv(): read error: Device not configured
avrdude: butterfly_recv(): programmer is not responding
avrdude: error: programmer did not respond to command: exit bootloader
avrdude: ser_close(): can’t reset attributes for device: Device not configured

PORTS {/dev/cu.Bluetooth-Incoming-Port, /dev/cu.usbmodem9, /dev/cu.usbmodemFA131, /dev/cu.usbmodemFD121, /dev/tty.Bluetooth-Incoming-Port, /dev/tty.usbmodem9, /dev/tty.usbmodemFA131, /dev/tty.usbmodemFD121, } / {/dev/cu.Bluetooth-Incoming-Port, /dev/cu.usbmodem9, /dev/cu.usbmodemFA131, /dev/cu.usbmodemFD121, /dev/tty.Bluetooth-Incoming-Port, /dev/tty.usbmodem9, /dev/tty.usbmodemFA131, /dev/tty.usbmodemFD121, } => {}
Uploading using selected port: /dev/cu.usbmodemFA131
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega32u4 -cavr109 -P/dev/cu.usbmodemFA131 -b57600 -D -Uflash:w:/var/folders/m1/3vsby4b100sdzl9w48tnqnw80000gn/T/arduino_build_719231/Blink.ino.hex:i

avrdude: Version 6.3-20190619
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is “/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf”
User configuration file is “/Users/bencefabian/.avrduderc”
User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/cu.usbmodemFA131
Using Programmer : avr109
Overriding Baud Rate : 57600
avrdude: ser_open(): can’t open device “/dev/cu.usbmodemFA131”: No such file or directory

avrdude done. Thank you.

Could someone help me find a solution to revive my board?

Error log.txt (19.7 KB)

The following might work.

Upload an innocent sketch, e.g. blink. When the IDE reports the memory usage indicating that the compile phase had completed, press and release the reset button.

I'm aware that there is no reset button on a ProMicro, so you might have to make a plan for that.

THANK YOU VERY MUCH. It worked! <3