SPI com failure

Background: using some Nano's connected to nrf24L01 to send data to a receiver. All is good until I ran out of Nano's. Bought some new ones and now they are not sending or receiving any data.

Troubleshooting: Verified correct wiring, used another nano, (windows updated on me) updated libraries, Swapped out for known good nrf24L01 and same fault... switch to a Mega2560 (and correct pins 50-53) and it worked.

What's going on with these Nano's? It seems like they are not talking on the SPI. What's going on and can I fix it?

(Decent programmer, advanced electronic background)

Cheap shit or originals?

Worked on original didn’t work on semi cheaper ones. I hooked up some RC522’s on the cheaper ones and it did work with them. Does the SPI clocks/mi/mo differ between modules?

sterretje:
Cheap shit or originals?

I don’t have much experience with SPI.

I think that there is a clock setting for SPI (not behind a PC at the moment); I would reduce that and see if it works.

There might be small differences (layout, components) between different ‘makes’ that might cause what you observe.