SPI Display doesnt work with Arduino Nano

I'm trying to use an SPI Display with an Arduino Nano, but it doesnt work.
Yesterday, I tried to turn it on, and worked a couple of times (some test images were displayed etc). Today, I tried to use it again and didnt worked. I changed my board (from NodeMCU -> Arduino Nano) and it didnt work too. I tried changing the display and it still dont worked. I checked all the connections a billion times and dont know what's the problem. Can anyone help me on this? How could I check if the display isnt working?

Link to the album with photos of the breadboard: https://photos.app.goo.gl/DUdampvBDcK42xHX7

@vitorfrois

Your topic was Moved to it's current location / section as it is more suitable.

Could you also take a few moments to Learn How To Use The Forum.

Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

Hi Vitorfrois,

Prepare for the worst: you might have fried the 3.3V display by wiring it to the (5V) Nano.
Can you supply pictures of your hardware AND a wiring diagram?
The folks here at the forum will try to help you, that's for sure, but they need i n f o r m a t i o n.
regards, photoncatcher

Best way to check displays like that is to connect them to a 3.3v Logic Pro Mini (or similar) Arduino.

vitorfrois:
I changed my board (from NodeMCU -> Arduino Nano) and it didn't work too.

Why would you do that? :roll_eyes:

This topic was automatically closed after 57 days. New replies are no longer allowed.