SPLC780D LCD and Arduino Uno

Hi,

I know this question has been asked alot of times around on different foras, but I have tried every suggestion i could find, and didn’t have any luck yet.

So, i’m trying to make the “Hello World” standard sketch to work, but gets the one row of blocks, nothing else.

I have followed Adafruits tutorial a couple of times. I have tried with and without the potentiometer. I now about the resistor thing, but i don’t have any problems with backlight, so i think it is included in the LCD IC.

I have also tried with 3,3v instead of 5v. 3.3 doesn’t seem to be enough for the lcd.

Also i have tried writing the pins from 12 - 7 and from 7-12, didn’t make a difference.

Furthermore i have tried connecting everything directly to the pins of the LCD.

The LCD is the; SPLC780D

Do you guys have any idea about how to solve this?

I have attached a photo of the connections and this is the code i have used (Helloworld template with adafruit pins"):

// include the library code:
#include <LiquidCrystal.h>

// initialize the library with the numbers of the interface pins
LiquidCrystal lcd(12, 11, 10, 9, 8, 7);

void setup() {
// set up the LCD’s number of columns and rows:
lcd.begin(16, 2);
// Print a message to the LCD.
lcd.print(“hello, world!”);
}

void loop() {
// set the cursor to column 0, line 1
// (note: line 1 is the second row, since counting begins with 0):
lcd.setCursor(0, 1);
// print the number of seconds since reset:
lcd.print(millis()/1000);
}

Your photo shows:

//                brown ...       orange          
LiquidCrystal lcd(7, 8, 9, 10, 11, 12);

but your sketch says:

LiquidCrystal lcd(12, 11, 10, 9, 8, 7);

It looks like a new-ish breadboard. I would always be suspicious of wires plugged into breadboards.

  1. change the constructor to match your actual wiring.
  2. if it sill does not work, replace each wire, one at a time until you find the bad wire.

David.

Hi again,

Thank you for your reply!

I just had a few problems with the arduino uno not being able to connect to the computer. Got a new one now.

I have tried with and without the breadboard without any luck. I have also changed the constructor line to match my wiring, and changed wiring and constructor line.

I have tried each wire and power flows through all of them :(

So annoying!

Maybe the LCD is broken?

Thanks