starting off with Mac OS

Hi All,

Just getting started, i have installed the Mac OS IDE, when run it i get a simple screen with a title "sketch_feb09a" and options to verify/upload/new/open/save and a script editing window. I belive i need to install the board but all the instructions on the site seem windows based. I cant actually connect the UNO board yet ( no usb cable) but thought i would get the full options on the IDE ie file examples etc etc tools etc. Am i missing something ?

You dont mean these MAC destructions do you ?

As far as anything else goes the board and USB cable are quite important and until you know what variety of UNO there isn't much point going further.

Link to source of purchase may be helpful ? Pic of the board around the USB connector may also be useful. (decent one please)

Also avoid USB 3.0 ports.

yes those exact instructions, i will get a picture but for now the reason i havnt connected the board is because i thought the starter kit i purchased had everything already. But no usb A-C cable, i will get one tomorrow. The board has UNO R3 SMD EDITION ON IT.

I was hoping to see a menu similar to what the book shows for windows but do i need the board connected ? to complete the installation of the IDE ?

Until you connect it there isnt much else to do right now.

Certainly play with the IDE and get the feel for it so that if you have issues later on you know what people are talking about if the ask for the output from the lower console, or verbose output etc.

ok thankyou i will hopefully have it connected tomorrow and see what happens

just realised i do have all the options so used to a windows desktop forgot the menus are up the top bar. Do i need to also install a processing IDE ? does this run in parrallel with the board IDE ?

Unless you have a specific use for processing then no you dont need it.

Besides its better to learn one thing at a time rather than confuse yourself with two.

ok i have the USB cable and have connected it, i set the board type to UNO and also saw that the USB port appeared so selected it for communication. On the board the user LED flashes so i see this means there is a boot loader installed. When i try to download the "blink" example sketch i get a compiler error for board type. and in the log i see many messages like below. In the start here section it suggests this might be because of an older MAC X version but i have 10.7.5, im sure the PC is communicating with the board as i can retrieve board info like serial number etc.

Arduino: 1.8.1 (Mac OS X), Board: "Arduino/Genuino Uno"

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/../lib/gcc/avr/4.9.2/../../../../avr/bin/ld: /Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/../libexec/gcc/avr/4.9.2/liblto_plugin.so: error loading plugin: dlopen(/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/../libexec/gcc/avr/4.9.2/liblto_plugin.so, 2): Symbol not found: _environ Referenced from: /Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/../libexec/gcc/avr/4.9.2/liblto_plugin.so Expected in: /usr/lib/libSystem.B.dylib

collect2: error: ld returned 1 exit status exit status 1 Error compiling for board Arduino/Genuino Uno.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

thought i would try loading the blink sketch then cutting and pasting it into the direct ide window manually i ended up with the below after quite a few program errors but still i get a cannot compile for board type uno ?

// the setup function runs once when you press reset or power the board void setup() { // initialize digital pin LED_BUILTIN as an output. pinMode(LED_BUILTIN, OUTPUT); }

// the loop function runs over and over again forever

void loop()

{ digitalWrite(LED_BUILTIN, HIGH); // turn the LED on (HIGH is the voltage level) delay(1000); // wait for a second digitalWrite(LED_BUILTIN, LOW); // turn the LED off by making the voltage LOW delay(1000); // wait for a second }

getting the board info is not that hard by any standard. What is harder is getting your mac to talk to it directly...

Not a mac person as such...but see lots of mac questions asked in regards to comms. You should be able to at least compile as that's not a com specific task.

Suggesting to do a search for your OS version in the forum and see what turns up.

i can see some similar issues but nothing spot on, is it possible to get an older version of the ide to try, as you say the compile is local yo the ide so its not even at the comms stage i might try the web ide later.

tried the web version but that just sits loading, then i see a message "not authorized to use CAS"

ok i tried IDE version 1.0.3, on installation i went and installed some Java plugin. So i thought after that i would go back to IDE 1.8.1 to see if any difference but no change. So i tried the 1.0.3 and this works i.e. it uploads and just to confirm i changed the blink sketch high timer 10000ms 10secs and uploaded again, the change worked. SO whats the issue with 1.8.1 IDE and MAC OS 10.7.5 ???? 1.0.3 seems a lot older so am i going to run into other issues ?

There may be issues with a really old IDE as some of the improvements wont get carried forward.

1.6.5 was quite reliable.

We have seen people try "similar issue fixes" and suddenly find they were off to the races. So don't discount them out of hand.

There are also the "portable" options of running the IDE which works well for some people.