Startup icon always on foreground

The startup icon is always displayed on foreground, even if I select another open program.

Hi @robbeserry. I'm sorry to hear Arduino IDE 2.x is giving you some troubles.

I'm not sure I understand what you mean by "startup icon". Are you referring to the splash screen:

Clipboard01.png

Clipboard01.png

I have the same issue. The "splash screen" does not close. Nothing happens when Im using the menus. sometimes there is a box with something behind the splash screen that i can close with enter.

Hi @needlegate. I think the thing to try for troubleshooting in this case will be to start the Arduino IDE 2.x from the command line. That will provide some output that might be useful in identifying the problem.

So if you can do that, please post the full output copied from the terminal in a reply here. It will probably be longer than the forum's 9000 character maximum limit. If so, save it to a text file and attach it to the reply. If you click the "Reply" button here, you'll see an "Attachments and other settings" link that will allow you to make the attachment.

If you like, I'm happy to provide detailed instructions for how to run Arduino IDE 2.x from the command line, but I'd first need to know which operating system you're using.

Im using win10

OK, here are the instructions for running Arduino IDE 2.x from the command line on Windows and getting the output:

  • Start File Explorer (AKA Windows Explorer).
  • Open the Arduino IDE’s installation folder (usually C:\Program Files\Arduino IDE or C:\Users\<user name>\AppData\Local\Programs\Arduino IDE)
  • In the folder listing of the Arduino IDE installation folder, hold the Shift key while clicking the right hand button on the mouse.
  • Click “Open PowerShell window here” (or “Open command window here” if using Windows 7). PowerShell (or cmd if using Windows 7) will now open with the current directory set to the Arduino IDE installation folder.
  • Type & ".\Arduino IDE" (or if using cmd, type "Arduino IDE").
  • Press Enter. Debug output should now be printed to the PowerShell window as the Arduino IDE starts (or fails to start).
  • Wait for the Arduino IDE to finish starting, or failing to start.
  • Switch back to the PowerShell window if the Arduino IDE window took the focus.
  • Right click on the title bar of the PowerShell window.
  • Click Edit > Select All. This will select all the text in the PowerShell window.
  • Press Ctrl + c. This will copy the contents of the PowerShell window to the clipboard.
  • In this Arduino forum thread, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply, making it easier for us to read.
  • Press Ctrl + V. This will paste the output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.
  • Click the “Post” button.

Hopefully that will give us some information we can use to help you with the problem.

Please let me know if anything is unclear.

PS C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2>
Starting backend process. PID: 9856
Configuring to accept webviews on '^.+\.webview\..+

Hello; I have the same problem “The startup icon is always displayed on foreground” hostname.

root WARN please install @theia/electron@1.11.0-next.c9db9754 as a runtime dependency
root INFO Configuration directory URI: 'file:///c%3A/Users/kimaa/.theia'
root INFO Theia app listening on http://localhost:57530.
root WARN The local plugin referenced by local-dir:/c%3A/Users/kimaa/.arduinoIDE/plugins does not exist.
root WARN The local plugin referenced by local-dir:/c%3A/Users/kimaa/.arduinoIDE/extensions does not exist.
root WARN The local plugin referenced by local-dir:C:\Users\kimaa\.arduinoProIDE\plugins does not exist.
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "cortex-debug" to a VS Code extension "cortex-debug@0.3.7" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-arduino-language-server" to a VS Code extension "vscode-arduino-language-server@0.0.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-cpp" to a VS Code extension "cpp@1.52.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-json" to a VS Code extension "json@1.46.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-json-language-features" to a VS Code extension "json-language-features@1.46.1" with engines:
root INFO Deploying backend plugin "cortex-debug@0.3.7" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\cortex-debug\extension\dist\extension"
root INFO Deploying backend plugin "vscode-arduino-language-server@0.0.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-arduino-language-server\extension\dist\bundle"
root INFO Deploying backend plugin "cpp@1.52.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-builtin-cpp\extension"
root INFO Deploying backend plugin "json@1.46.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-builtin-json\extension"
root INFO Deploying backend plugin "json-language-features@1.46.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-builtin-json-language-features\extension\client\dist\jsonMain"
root INFO Deploy plugins list took: 123.7 ms
root WARN Backend ConfigServiceImpl.onStart is slow, took: 224.4 ms
daemon INFO Starting daemon from C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\node_modules\arduino-ide-extension\build\arduino-cli.exe...
daemon INFO Using config file: c:\Users\kimaa\.arduinoIDE\arduino-cli.yaml
daemon INFO arduino-cli.exe version 0.16.1
daemon INFO Setting up Prometheus metrics on :9090/metrics
daemon INFO Starting daemon on TCP address 127.0.0.1:50051
daemon INFO Daemon is now listening on 127.0.0.1:50051...
daemon INFO Daemon is running.
root ERROR Could create client for gRPC.
root INFO Git askpass helper is listening on http://127.0.0.1:57537.
root WARN Frontend CommonFrontendContribution.configure is slow, took: 550.3 ms
root WARN Failed to resolve module: @types/body-parser
root WARN Failed to resolve module: @types/cookie
root WARN Failed to resolve module: @types/express
root WARN Failed to resolve module: @types/fs-extra
root WARN Failed to resolve module: @types/lodash.debounce
root WARN Failed to resolve module: @types/lodash.throttle
root WARN Failed to resolve module: @types/react
root WARN Failed to resolve module: @types/react-dom
root WARN Failed to resolve module: @types/react-virtualized
root WARN Failed to resolve module: @types/route-parser
root WARN Failed to resolve module: @types/safer-buffer
root WARN Failed to resolve module: @types/ws
root WARN Failed to resolve module: @types/yargs
root WARN Failed to resolve module: @theia/monaco
root WARN Failed to resolve module: @theia/editor
root WARN Failed to resolve module: @types/rimraf
root WARN Failed to resolve module: @types/tar-fs
root WARN Failed to resolve module: @types/uuid
root WARN Failed to resolve module: @theia/navigator
root WARN Failed to resolve module: @types/p-queue
root WARN Failed to resolve module: @theia/preferences
root WARN Failed to resolve module: @theia/electron
root WARN Failed to resolve module: @theia/messages
root WARN Failed to resolve module: @types/diff
root WARN Failed to resolve module: @types/dompurify
root WARN Failed to resolve module: @types/mime
root WARN Failed to resolve module: @types/request
root WARN Failed to resolve module: @types/dateformat
root WARN Failed to resolve module: @types/deepmerge
root WARN Failed to resolve module: @types/glob
root WARN Failed to resolve module: @types/google-protobuf
root WARN Failed to resolve module: @types/js-yaml
root WARN Failed to resolve module: @types/ncp
root WARN Failed to resolve module: @types/ps-tree
root WARN Failed to resolve module: @types/react-select
root WARN Failed to resolve module: @types/react-tabs
root WARN Failed to resolve module: @types/sinon
root WARN Failed to resolve module: @types/temp
root WARN Failed to resolve module: @types/which
root WARN Failed to resolve module: temp
root INFO Using Git [2.30.0.windows.1] from the PATH. (C:\Program Files\Git\cmd\git.exe)
root ERROR TypeError: Failed to fetch

Hello; I have the same problem “The startup icon is always displayed on foreground”

Hi @kimaali. I see the creation of the gRPC client was not possible. Arduino IDE 2.x communicates with the Arduino CLI tool that handles all the non-GUI related tasks over port 50051. I think this problem is caused by Arduino IDE somehow not being able to open this port.

One thing you could try is described by the lead Arduino IDE 2.x developer here:

The CLI config is under C:\Users\your_user_name.arduinoIDE\arduino-cli-config.yaml on Windows. Stop the app, open this file with your favorite text editor, and change the default 50051 port to something else. Let us know how it worked. Thanks!

So please give that a try and if that doesn’t work I’ll try to come up with something else you can try.

Hi; I changed the port value but the same problem; I try different values.

pert:
Hi @robbeserry. I'm sorry to hear Arduino IDE 2.x is giving you some troubles.

I'm not sure I understand what you mean by "startup icon". Are you referring to the splash screen:

Clipboard01.png

Yes the splash screen appears in front of everything. Once the program is loaded and a sketch is visible, it disappears.

robbeserry:
Yes the splash screen appears in front of everything. Once the program is loaded and a sketch is visible, it disappears.

OK, that's the normal behavior. So are you having any problems using Arduino IDE 2.0.0-beta.3?

kimaali:

PS C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2>

Starting backend process. PID: 9856
Configuring to accept webviews on '^.+.webview..+



Hello; I have the same problem "The startup icon is always displayed on foreground"

Hello,
I have a similar problem, log file has mostly the same entries.
I also get this message:
root ERROR Error: Git installation not found.
at C:\m\arduino-ide_2.0.0-beta.3_Windows_64bit\resources\app\node_modules\find-git-exec\lib\find-git-exec.js:69:69
Is GIT installation required to run ArduinoIDE?
I use the zip version of ArduinoIDE, not the installer.
Thanks.
hostname.
root WARN please install @theia/electron@1.11.0-next.c9db9754 as a runtime dependency
root INFO Configuration directory URI: 'file:///c%3A/Users/kimaa/.theia'
root INFO Theia app listening on http://localhost:57530.
root WARN The local plugin referenced by local-dir:/c%3A/Users/kimaa/.arduinoIDE/plugins does not exist.
root WARN The local plugin referenced by local-dir:/c%3A/Users/kimaa/.arduinoIDE/extensions does not exist.
root WARN The local plugin referenced by local-dir:C:\Users\kimaa.arduinoProIDE\plugins does not exist.
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "cortex-debug" to a VS Code extension "cortex-debug@0.3.7" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-arduino-language-server" to a VS Code extension "vscode-arduino-language-server@0.0.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-cpp" to a VS Code extension "cpp@1.52.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-json" to a VS Code extension "json@1.46.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-json-language-features" to a VS Code extension "json-language-features@1.46.1" with engines:
root INFO Deploying backend plugin "cortex-debug@0.3.7" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\cortex-debug\extension\dist\extension"
root INFO Deploying backend plugin "vscode-arduino-language-server@0.0.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-arduino-language-server\extension\dist\bundle"
root INFO Deploying backend plugin "cpp@1.52.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-builtin-cpp\extension"
root INFO Deploying backend plugin "json@1.46.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-builtin-json\extension"
root INFO Deploying backend plugin "json-language-features@1.46.1" from "C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\plugins\vscode-builtin-json-language-features\extension\client\dist\jsonMain"
root INFO Deploy plugins list took: 123.7 ms
root WARN Backend ConfigServiceImpl.onStart is slow, took: 224.4 ms
daemon INFO Starting daemon from C:\Users\kimaa\AppData\Local\Programs\Arduino IDE2\resources\app\node_modules\arduino-ide-extension\build\arduino-cli.exe...
daemon INFO Using config file: c:\Users\kimaa.arduinoIDE\arduino-cli.yaml
daemon INFO arduino-cli.exe version 0.16.1
daemon INFO Setting up Prometheus metrics on :9090/metrics
daemon INFO Starting daemon on TCP address 127.0.0.1:50051
daemon INFO Daemon is now listening on 127.0.0.1:50051...
daemon INFO Daemon is running.
root ERROR Could create client for gRPC.
root INFO Git askpass helper is listening on http://127.0.0.1:57537.
root WARN Frontend CommonFrontendContribution.configure is slow, took: 550.3 ms
root WARN Failed to resolve module: @types/body-parser
root WARN Failed to resolve module: @types/cookie
root WARN Failed to resolve module: @types/express
root WARN Failed to resolve module: @types/fs-extra
root WARN Failed to resolve module: @types/lodash.debounce
root WARN Failed to resolve module: @types/lodash.throttle
root WARN Failed to resolve module: @types/react
root WARN Failed to resolve module: @types/react-dom
root WARN Failed to resolve module: @types/react-virtualized
root WARN Failed to resolve module: @types/route-parser
root WARN Failed to resolve module: @types/safer-buffer
root WARN Failed to resolve module: @types/ws
root WARN Failed to resolve module: @types/yargs
root WARN Failed to resolve module: @theia/monaco
root WARN Failed to resolve module: @theia/editor
root WARN Failed to resolve module: @types/rimraf
root WARN Failed to resolve module: @types/tar-fs
root WARN Failed to resolve module: @types/uuid
root WARN Failed to resolve module: @theia/navigator
root WARN Failed to resolve module: @types/p-queue
root WARN Failed to resolve module: @theia/preferences
root WARN Failed to resolve module: @theia/electron
root WARN Failed to resolve module: @theia/messages
root WARN Failed to resolve module: @types/diff
root WARN Failed to resolve module: @types/dompurify
root WARN Failed to resolve module: @types/mime
root WARN Failed to resolve module: @types/request
root WARN Failed to resolve module: @types/dateformat
root WARN Failed to resolve module: @types/deepmerge
root WARN Failed to resolve module: @types/glob
root WARN Failed to resolve module: @types/google-protobuf
root WARN Failed to resolve module: @types/js-yaml
root WARN Failed to resolve module: @types/ncp
root WARN Failed to resolve module: @types/ps-tree
root WARN Failed to resolve module: @types/react-select
root WARN Failed to resolve module: @types/react-tabs
root WARN Failed to resolve module: @types/sinon
root WARN Failed to resolve module: @types/temp
root WARN Failed to resolve module: @types/which
root WARN Failed to resolve module: temp
root INFO Using Git [2.30.0.windows.1] from the PATH. (C:\Program Files\Git\cmd\git.exe)
root ERROR TypeError: Failed to fetch



Hello; I have the same problem "The startup icon is always displayed on foreground"

Hello,
I have a similar problem, log file has mostly the same entries.
I also get this message:
root ERROR Error: Git installation not found.
at C:\m\arduino-ide_2.0.0-beta.3_Windows_64bit\resources\app\node_modules\find-git-exec\lib\find-git-exec.js:69:69
Is GIT installation required to run ArduinoIDE?
I use the zip version of ArduinoIDE, not the installer.
Thanks.

pert:
OK, here are the instructions for running Arduino IDE 2.x from the command line on Windows and getting the output:

  • Start File Explorer (AKA Windows Explorer).
  • […]

Hello,
here is the debug output of the failing start of arduino-ide_2.0.0-beta.4_Windows_64bit (zip version):

PS C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit> & ".\Arduino IDE"
PS C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit>
Starting backend process. PID: 8884
Configuring to accept webviews on '^.+\.webview\..+

Can you please help me?
Thanks.

 hostname.
root WARN please install @theia/electron@1.11.0-next.c9db9754 as a runtime dependency
root INFO Configuration directory URI: 'file:///c%3A/Users/xyz/.theia'
root INFO Theia app listening on http://localhost:50606.
root WARN The local plugin referenced by local-dir:/c%3A/Users/xyz/.arduinoIDE/plugins does not exist.
root WARN The local plugin referenced by local-dir:/c%3A/Users/xyz/.arduinoIDE/extensions does not exist.
root WARN The local plugin referenced by local-dir:C:\Users\xyz\.arduinoProIDE\plugins does not exist.
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "cortex-debug" to a VS Code extension "cortex-debug@0.3.7" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-arduino-tools" to a VS Code extension "vscode-arduino-tools@0.0.1-beta.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-cpp" to a VS Code extension "cpp@1.52.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-json" to a VS Code extension "json@1.46.1" with engines:
root INFO PluginTheiaDirectoryHandler: accepting plugin with path
root INFO Resolved "vscode-builtin-json-language-features" to a VS Code extension "json-language-features@1.46.1" with engines:
root INFO Deploying backend plugin "cortex-debug@0.3.7" from "C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit\resources\app\plugins\cortex-debug\extension\dist\extension"
root INFO Deploying backend plugin "vscode-arduino-tools@0.0.1-beta.1" from "C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit\resources\app\plugins\vscode-arduino-tools\extension\dist\bundle"
root INFO Deploying backend plugin "cpp@1.52.1" from "C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit\resources\app\plugins\vscode-builtin-cpp\extension"
root INFO Deploying backend plugin "json@1.46.1" from "C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit\resources\app\plugins\vscode-builtin-json\extension"
root INFO Deploying backend plugin "json-language-features@1.46.1" from "C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit\resources\app\plugins\vscode-builtin-json-language-features\extension\client\dist\jsonMain"
root INFO Deploy plugins list took: 58.4 ms
root WARN Backend ConfigServiceImpl.onStart is slow, took: 158.6 ms
daemon INFO Starting daemon from C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit\resources\app\node_modules\arduino-ide-extension\build\arduino-cli.exe...
daemon INFO Using config file: c:\Users\xyz\.arduinoIDE\arduino-cli.yaml
daemon INFO arduino-cli.exe version 0.17.0
daemon INFO Setting up Prometheus metrics on :9090/metrics
daemon INFO Starting daemon on TCP address 127.0.0.1:50051
daemon INFO Daemon is now listening on 127.0.0.1:50051...
daemon INFO Daemon is running.
daemon INFO Checking if CLI is Bundled into the IDE
daemon INFO Loading hardware from: C:\Users\xyz\AppData\Local\Arduino15\packages
daemon INFO Adding libraries dir [dir: C:\Users\xyz\Documents\Arduino\libraries, location: user]
root INFO Git askpass helper is listening on http://127.0.0.1:50615.
root ERROR Error: Git installation not found.
    at C:\m\arduino-ide_2.0.0-beta.4_Windows_64bit\resources\app\node_modules\find-git-exec\lib\find-git-exec.js:69:69
root WARN Frontend CommonFrontendContribution.configure is slow, took: 408.5 ms
root WARN Failed to resolve module: @types/body-parser
root WARN Failed to resolve module: @types/cookie
root WARN Failed to resolve module: @types/express
root WARN Failed to resolve module: @types/fs-extra
root WARN Failed to resolve module: @types/lodash.debounce
root WARN Failed to resolve module: @types/lodash.throttle
root WARN Failed to resolve module: @types/react
root WARN Failed to resolve module: @types/react-dom
root WARN Failed to resolve module: @types/react-virtualized
root WARN Failed to resolve module: @types/route-parser
root WARN Failed to resolve module: @types/safer-buffer
root WARN Failed to resolve module: @types/ws
root WARN Failed to resolve module: @types/yargs
root WARN Failed to resolve module: @theia/monaco
root WARN Failed to resolve module: @theia/editor
root WARN Failed to resolve module: @types/rimraf
root WARN Failed to resolve module: @types/tar-fs
root WARN Failed to resolve module: @types/uuid
root WARN Failed to resolve module: @theia/navigator
root WARN Failed to resolve module: @types/p-queue
root WARN Failed to resolve module: @theia/preferences
root WARN Failed to resolve module: @theia/electron
root WARN Failed to resolve module: @theia/messages
root WARN Failed to resolve module: @types/diff
root WARN Failed to resolve module: @types/dompurify
root WARN Failed to resolve module: @types/mime
root WARN Failed to resolve module: @types/request
root WARN Failed to resolve module: @types/dateformat
root WARN Failed to resolve module: @types/deepmerge
root WARN Failed to resolve module: @types/glob
root WARN Failed to resolve module: @types/google-protobuf
root WARN Failed to resolve module: @types/js-yaml
root WARN Failed to resolve module: @types/ncp
root WARN Failed to resolve module: @types/ps-tree
root WARN Failed to resolve module: @types/react-select
root WARN Failed to resolve module: @types/react-tabs
root WARN Failed to resolve module: @types/sinon
root WARN Failed to resolve module: @types/temp
root WARN Failed to resolve module: @types/which
root WARN Failed to resolve module: js-yaml
root WARN Failed to resolve module: temp
root ERROR Could not create client for gRPC.

Can you please help me?
Thanks.

Hi @looking. I apologize for not having responded. Unfortunately, I have not been able to discover any troubleshooting techniques to allow me to investigate this "Could not create client for gRPC" issue. It's a difficult situation because I can't reproduce the problem on my own system. The IDE starts up fine for me. This is the irony of doing support and development. While the users only want the bug to go away, we are desperately wishing it would occur for us.

I have reported this to the Arduino IDE developers. Hopefully they will be able to find a solution to allow you to start using the Arduino IDE 2.x beta in an upcoming release.

Hello everyone. I was finally able to reproduce this “Could not create client for gRPC” issue. I think this will be a good step forward in the investigation of the issue, but I’m not 100% sure that the cause for the error I found is the same as the one affecting you. So it will be extremely useful if you can help me out by trying something on your computer and then reporting the results here.


Please rename this folder:

C:\Users\<user name>\Documents\Arduino\libraries

to this:

C:\Users\<user name>\Documents\Arduino\libraries.disable

In the above paths, replace “” with your Windows user name.

Now try to start Arduino IDE 2.x. If it’s more convenient for you, you can just start it normally rather than via the command line.

Please let me know if the Arduino IDE 2.x now starts fully for you, or whether you still have the same problem as before where it hangs on the splash screen.

Please don’t delete the “libraries.disable” folder. If we find that renaming the folder allows the IDE to start, I’m hoping you’ll be able to share the contents of the “libraries.disable” folder with me so I can determine exactly what it is in there causing the problem.

Please let me know if anything is unclear or if you run into any problems.

Thanks in advance!
Per

pert:
Hello everyone. I was finally able to reproduce this “Could not create client for gRPC” issue. I think this will be a good step forward in the investigation of the issue, but I’m not 100% sure that the cause for the error I found is the same as the one affecting you. So it will be extremely useful if you can help me out by trying something on your computer and then reporting the results here.


Please rename this folder:

C:\Users\<user name>\Documents\Arduino\libraries

to this:

C:\Users\<user name>\Documents\Arduino\libraries.disable

In the above paths, replace “” with your Windows user name.

Now try to start Arduino IDE 2.x. If it’s more convenient for you, you can just start it normally rather than via the command line.

Please let me know if the Arduino IDE 2.x now starts fully for you, or whether you still have the same problem as before where it hangs on the splash screen.

Please don’t delete the “libraries.disable” folder. If we find that renaming the folder allows the IDE to start, I’m hoping you’ll be able to share the contents of the “libraries.disable” folder with me so I can determine exactly what it is in there causing the problem.

Please let me know if anything is unclear or if you run into any problems.

Thanks in advance!
Per

Hello,
unfortunately Arduino IDE 2.x still does not start fully.
In folder

C:\Users\<user name>\Documents\Arduino\libraries

there is only one file readme.txt.

Hi @looking. The developer of Arduino IDE 2.x has now made an improvement in how it handles this type of error. It's not a fix, but it provides a detailed error output right in the GUI. So we get more information about the problem and it's visible to people even if they didn't start from the command line. I think it might help us to identify what is causing this on your system.

This is now available from a tester build. If you don't mind, please do this:

  • Log in to a GitHub account. I'm hoping you have one because the tester builds are only available for download when you're logged in. If not, you can wait a few days for it to become available in the nightly build.
  • Open this page: ATL-1137: Show error when could not connect to CLI · arduino/arduino-ide@33dcb5c · GitHub
  • From under the "Artifacts" section of the page, click on "Windows_X86-64_zip" (or you can click on one of the Windows installer versions if you prefer that).
  • Wait for the download to finish.
  • Unzip the downloaded file.
  • Unzip the file inside the unzipped folder (yes, I know that's silly, but it's a restriction of the GitHub system). Or if you downloaded the installer version then run the installer.
  • Start the "Arduino IDE.exe" from inside the unzipped folder (or the installation if you used the installer).
  • If all goes well, the IDE should get past the splash screen and show an error notification in a box at the bottom right corner of the IDE window. If so, please copy and paste the full text in a reply here.

pert:
If all goes well, the IDE should get past the splash screen and show an error notification in a box at the bottom right corner of the IDE window. If so, please copy and paste the full text in a reply here.

IDE gets now past the splash screen and works.
Notifications:

Request loadSketch failed with message: 2 UNKNOWN: downloading builtin:ctags@5.8-arduino11 tool: Get "https://downloads.arduino.cc/tools/ctags-5.8-arduino11-pm-i686-mingw32.zip": dial tcp 104.18.28.45:443: connectex: No connection could be made because the target machine actively refused it.
There was an error creating the sketch directory. See the log for more details. The application will probably not work as expected.

After that, I set a proxy in "Preferences => Network" and restarted the IDE.
Now there is only one notification:

An unexpected error occurred when locating the Git executable.

Thanks so much for the update @looking!

looking:
After that, I set a proxy in "Preferences => Network" and restarted the IDE.

Great work! Were you previously able to use the classic Arduino IDE (e.g., 1.8.13) without the need for any network configuration? If so, that is probably because the automatic proxy configuration system feature the classic IDE has is not yet implemented in Arduino IDE 2.0.0:

looking:
Now there is only one notification:

An unexpected error occurred when locating the Git executable.

This can safely be ignored. Arduino IDE 2.0.0 has an optional Git integration feature which requires it to be able to access an existing Git installation. However, all the normal functionality of the IDE will work perfectly even without Git, so this doesn't actually indicate a problem. The issue of this error message being a bad user experience is tracked here:

Hopefully that will be resolved in an upcoming release.

Another strange behavior of the startup logo:
If the program is reduced to half the screen width, the logo is displayed in the middle of the screen at program start. This is not so common in the Windows world!