Static-damaged Nanos

New to arduino here. I'm working with some nano clones and am having comms issues...the regular avrdude errors. Looks like they came with the blink sketch uploaded (I have power LED and blinking L LED) but I can't get any code to upload. I've tried 5 units of the same batch so far and all have the same symptom.
I just uploaded the code I am working with on a known working nano from the project bin and had no issues so the code is good. Both are outfitted with CH340G so I don't think it's a driver issue.
One thing to note I guess is that the successful unit has the 340 mounted on the bottom of the pcb and the ones that don't work are a different design with everything mounted on top.
I guess the question is, what is the protocol for this issue? I don't mind diving in deeper and getting a programmer but I'd rather not if the units are likely damaged beyond repair. I already have a bad DIY electronics habit and the more I can do to avoid discovering more corners of the hobby to sink my money into the better!

Have you tried both the new and old bootloader?

Look at the nano board closely and make sure you do not have an atmega168 processor instead of the atmega328.

Can you share top and bottom pictures of the non working units?

Legend. I tried everything EXCEPT double checking the processor. Thanks for helping out an idiot in need!

1 Like