Steering Movement Problem

I am using a scrap ride on jeep i have connected my arduino board to L293 which is an H bridge IC but my steering is not moving i am using two 6V 10Amp Batteries in series it not moving kindly guide me

Connect a meter to the H-bride inputs to see if you are driving them properly. If not, fix your code.

johnwasser: Connect a meter to the H-bride inputs to see if you are driving them properly. If not, fix your code.

"Scrap ride on jeep"? L293?

It sounds like the OP is (somehow) expecting to be able to control a....

You know - before I shoot my mouth off much - maybe the OP can give us some details:

  1. What kind of "scrap ride on jeep" is this thing?
  2. What are the specs of the motors involved?
  3. Maybe some pics, some schematics, maybe some code - something?

I mean - for all I know the OP is trying to drive a large 5 amp gear motor using his L293; that ain't gonna work well...

How does a L293 make a stearing wheel turn? :~

zoomkat: How does a L293 make a stearing wheel turn? :~

I have a feeling that the OP is trying to control some largish gearmotor of dubious specs using an L293 to actuate the steering on a Barbie Powerwheels (or similar) Jeep; given that the OP is using 12 volts, its likely not the smaller 6 volt Jeep, but the larger "full size" one...

If this is the case, then the motor used is likely needing waaaay more than the 1 amp the L293 can provide (if the L293 hasn't had its magic smoke liberated)...

The below discussion might sum up some of the issues.

http://arduino.cc/forum/index.php/topic,87167.0.html

thanks but i am done with this i have got a mechanical Issue

can any body tell me why my board is getting reset while i move the steering

cutebuddy6: can any body tell me why my board is getting reset while i move the steering

1) Programming error 2) Insufficient RAM 3) Electrical problem such as voltage drop.

293291)Programming Error -->the code is working fine 2)Insufficent RAM -->What will RAM do when i am Moving the code 3) Electrical problem such as voltage drop. -->this might be the issue because with the Ride on Jeep Motor you cant use L293 because the motor requires More Power than it. we developed a relay logic for it to give the direct power to the steering Motor but its getting reset

->What will RAM do when i am Moving the code

What does this mean?

Is Ram concerned with the following issue?

---> i think its the issue of Voltage drop because -->the when it on Moving Left it require a Lot of power to move it i think that the motor and the relay is Producing Back emf i have place diode for it and don't know the other concerned issue

cutebuddy6: 1)Programming Error -->the code is working fine

Excellent! Glad you found and fixed the problem.

well but my Arduino is getting Reset after each turn

Oh. Is that A Bad Thing?

yes but Now my IC is not working its not Loading the Program

cutebuddy6: yes but Now my IC is not working its not Loading the Program

that Is unfortunate. Time To replace That Ic.

i want to now what i have done wrong with my arduino that my IC is not working

Please, everyone, hands on the ouija board.

cutebuddy6: i want to now what i have done wrong with my arduino that my IC is not working

Me too!