Stepper dies when ethernet library connect to client..... :(

:confused:

Hi guys. I really not so much into interrupt timers and so. So if someone could help my understand, what the problem Im facing is…

Im using this library to communicate with a siemens S7-1200 controller:
http://settimino.sourceforge.net

My problem is that when i connect with this library to my PLC (S7-1200) my stepper stops working. Ive tried almost every single stepper library.

I tried:
AccelStepper.h
Big_Easy_Driver.h
Stepper.h

My best guess is something with Timer0 or other While loops.?

Really hope there somenone in here, that have the knowledge to help me.

Br
Kasper.

Settimino-1.zip (1.07 MB)

What is in that HUGE zip file?

Can you just post your .ino file either inline or as an attachment?

My wild guess is that the connection process you mention blocks while it is working and the Arduino just has to wait. If so it is very poor design.

...R

The file is the library for the ethernet protocol. I thought it was a good idea to attach it, if someone could look at it.. :/

The library on its own is no good. We also need to see your program that uses the library.

...R