Stepper motor voltage

Hello All. I've got a stepper motor from an Epson printer. I connected it to a motor shield from Adafruit. The code I'm using is working, making it turn as directed. However, it has very little torque. I have the service manual for the printer and was able to identify the correct coil wires. Adafruit's data for the shield directs the common wire of this 5 wire stepper go to ground. When in use in the printer the stepper's common wire goes to 42V. The voltage I supplied to the stepper via the shield was 12V. The stepper motor worked when the common was connected to ground. I tried connecting the common to 12V and the stepper motor didn't work at all. Is this difference in where the common should be attached to (motor shield ground vs. printer circuit 42V) because the shield is sourcing current and the printer circuit is sinking it? Do you think the lack of torque is most likely due to the lack of voltage? Thanks - Scotty

yes... the name plate voltage of a stepper motor is generally much less than what the motor is supplied with, expect it is switched at a high rate to avoid motor heating (aka melting it) check out this link for some great background on how to power a stepper motor (click stepper faq)

edit -- i re-read your post, i'm not sure this applies to 5-wire steppers... :/ sorry edit 2 -- my personal experience with low torque motor problem was a blown driver chip.

good luck

Thanks Jonnym for your response and the link. Just want to make it understood that the voltage of 42V comes from the schematics, not a nameplate. - Scotty