Stepper using uln2004, external power


I’m playing with controller a unipolar stepper motor using a uln2004a chip. I have the all the demo sketches working fine and there’s not a problem running the sketches to operate the stepper.

Where my problem comes in is trying to use external power rather than the Arduino power.

My wiring follows the example pretty much exactly as here:

The difference I have in wiring is that when I run the Arduino 5+ line to the breadboard power then the stepper runs fine and all works. But when I remove the Arduino 5+ and replace with a 9v battery I get no action from the stepper; actually I vibrates a bit but does not move.

Attached is a pic of the setup, plus a closeup. It shows the 9v battery hooked up. In this manner there is no stepper movement. If remove the 9v wires and simply plug the green 5v from the Arduino (arrow pointing to it) and plug that into the rail (second arrow pointing right) then the stepper runs fine.

The vertical rail on the left is being used as the positive, and the vertical rail on the right is negative.

The power from the positive rail goes via the yellow wire to the row of 4 wires together and from there to the common (pin 16) on the u2004, same as the tutorial diagram.

The u2004 pin 8 (gnd) goes to the negative rail on the right (white wire). The arduino GND wire is also going to the far right negative rail (long blue wire).

I feel my wiring is exactly as the tutorial wiring (above link) so I’m befuddled why the external power does not work.

I’m still new to electronics and I’m more into the digital electronic aspect (controlling things software) and not the analog aspect, and while I appreciate any help, if you start talking big electronic words an concepts to me, my eyes will glaze over.

Also, if suggestions will be to use capacitors and/or resistors, etc, then why are they not depicted in the tutorial diagram? I presume the tutorial works as is and does not need extra components not listed.

Thanks for any help/comments.



I don't knoiw much about bread boards as I never use them, I prefer to solder to avoid faulty contacts, etc. Anyways, is there continuity between the rails where you have your battery connected and the rail where you connect the power fromn arduino?. In the pic it looks you have plugged the battery into different rails. Try plugging the battery to the same railing section where all the other wires are.

hey ... yes, checked the continuity; power was flowing all the way up the rail.

However ... I did discover the issue; turns out the battery did not have enough power to push the amps needed; I must have made the little arduino sweat, not realize how much amps were needed. I went and got a wall wart power source and that was able to push the stepper to run as the external power.

Thanks for the input, though.

Cheers, Eric

Glad you solved. Good Luck.